ReportsMagic V2 仮想プリンタドライバ 追加情報

本文書には､ReportsMagic V2 仮想プリンタドライバ （RM Printer）として提供されたプログラムに関して、マニュアルの記載事項以外の追加情報が記述されています。

  • インストール／アンインストール

  • プリンタドライバの印刷設定

  • 共有プリンターの設定

  • プリンタ定義ファイルの作成

  • 動作環境

  • 制限事項

  • 使用許諾契約

インストール／アンインストール

初期インストール

ReportsMagic製品CDよりインストーラ、又はアップデートモジュールを起動してインストールします。

アンインストール

コントロールパネル／プログラムの追加と削除で「ReportsMagic Printer Driver」を選択して削除します。

手作業でのアンインストール、インストール

プリンタードライバを手作業でアンインストール、インストールすることができます。　プリンタ定義ファイルの作成し更新する場合等に使用します。
アンインストール

RmInst.exe uninstall

インストール

RmInst.exe install [モジュール格納フォルダ] [プリンタ名] [プロセッサ種別(x86、又はx64）]

（例）
RmInst.exe install "C:\Program Files\ReportsMagic\RMPrinter" "RM Printer" x86

  • RmInst.exeは、インストールしたフォルダに格納されています。

プリンタドライバの印刷設定

プリンタの印刷設定より、各種のデフォルト値を設定することが可能です。

基本設定

  • デフォルトの用紙サイズ、用紙の向き、解像度を設定します。

ファイル保存の設定

  • ファイル保存先：
    デフォルト値は、c:\になっていますが、最新のOSではセキュリティ上保存できない場合があります。

  • ログ：
    プリンタドライバのログ（RMPrinter.log）の種類を選択します。
    なし／エラー時（デフォルト値）／カスタム／詳細から選択します。　出力先はファイル保存先です。

  • スプール分割サイズ：
    拡張フラットファイルのスプール分割サイズを指定します。　デフォルトは100M。　メモリ不足等の問題が発生する場合は小さくします。

実行時の設定

  • 実行時の設定：
    RMDesigner のツール／帳票設定／実行時動作設定と同等の機能を提供するもので、RMViewer起動時の実行動作のデフォルト値を設定します。　RMViewer起動時にパラメータを指定した場合は、パラメータが優先されます。

  • 印刷結果の表示：
    開発環境のみで有効で、セットしておくと仮想プリンタドライバからフラットファイルを生成後、自動的にRMViewerが起動されます。 　通常、開発環境でのテスト確認に使用します。

共有プリンターの設定

サーバ上の仮想プリンタドライバをネットワークプリンタとしてクライアントPC側から共有して使用することができます。
拡張フラットファイルの作成は、サーバ側で作成される為、クライアント側の負担は少なくなります。

詳細は、RMDesigner リファレンスマニュアルの仮想プリンタドライバを参照してください。

プリンタ定義ファイルの作成

プリンタ定義ファイルの作成を行うと、用紙サイズをカスタマイズすることができます。

手順

  1. プリンタ定義テキストファイル（RMPrinter.txt）をテキストエディタで編集します。

  2. 用紙サイズの設定コマンド（RmGpc.exe）を実行してプリンタ定義ファイル（RMPrinter.pdd）を作成します。

  3. プリンタドライバを一度アンインストールし、再度インストールを手作業で実行します。

プリンタ定義テキストファイルの編集
用紙名 用紙サイズ番号　用紙のサイズ　　　余白
;FormInfo {"Sample1", 0, 215900, 279400, 0, 0, 0, 0 }
;FormInfo {"Sample2", 0, 279400, 431800, 0, 0, 0, 0 }
;FormInfo {"Sample3", 0, 279400, 431800, 0, 0, 0, 0 }

  • 用紙サイズ番号が0以外はスプーラで定義しているので、変更できません。

  • 用紙サイズ番号が0は、カスタムサイズなので、用紙名、用紙サイズは自由に設定することができます。
    この場合、用紙番号は、インストール時に値が割り振られます。

  • Sample1～3を使用する場合は、先頭の;を外してください。

  • 余白は0以外対応していません。

用紙サイズの設定コマンドの実行

RmGpc.exe [プリンタ定義テキストファイル] RMPrinter.pdd

(例）RmGpc.exe RMPrinter.txt RMPrinter.pdd

動作環境

用途 | サポートOS | 備考
運用環境 | 【サーバ】 Windows2003 （x86） Windows2008 （x86） （x64） Windows2012 （x64） |
 | 【クライアント】 WindowsXP／Vista Windows 7 （x86） （x64） Windows 8 （x86） （x64） | サーバ上の仮想プリンタドライバをネットワークプリンタとして使用
開発環境 | Windows2003 （x86） Windows2008 （x86） （x64） Windows2012 （x64） WindowsXP／Vista Windows 7 （x86） （x64） Windows 8 （x86） （x64） |

  • プロセッサは、Intel x86アーキテクチャ、およびその互換プロセッサのみサポートしています。

  • 運用環境では、サーバ製品（RMViewer Web、RMViewer RichClient）でのみ使用する事が可能です。

  • Windows2003 のx64はサポートされていません。

制限事項

  • Magicアプリケーション以外での仮想プリンタドライバの使用はサポート対象外となります。
  • 通常のReportsMagicフォーム＋印刷データのように分離されて管理されていないため、フラットファイル容量は大きくなります。 PDFに比べてファイルサイズが大きくなる場合があります。


Magic Software Japan K.K - Magic eDeveloper Plus Ver9.40J SP1 ベータ版 （Windows版）

ReportsMagic 使用許諾契約書

MSJC-RM002

本ソフトウェアモジュールを利用するにあたっては、下記の事項を良く理解し、合意した上でご利用ください。万一合意できない場合には、本ソフトウェアモジュールをご利用になることはできません。

マジックソフトウェア・ジャパン株式会社（以下「ＭＳＪ」という）とお客様（以下「お客様」という）は、このパッケージに同封されているソフトウェア・プログラム（以下「許諾プログラム」という）及び同封物（マニュアルなど）について以下の通り合意しました。なお、本契約書に関するお問い合わせは、マジックソフトウェア・ジャパン株式会社（以下「ＭＳＪ」という）まで書面にてご連絡いただきますようお願い致します。

1. | 総則
   許諾プログラムに関する全ての著作権は、ＭＳＪが保有しています。ＭＳＪはお客様に、以下条項の規定に従って、許諾プログラムの譲渡不能かつ非独占的で限定された使用権を許諾するものであり、販売するものではありません。
2. | 契約期間
   本契約は、お客様がこのパッケージを開封した時から発効し、お客様が文書により解約を申し入れるか、または第７条の規定により解約されるまで有効とします。
3. | 使用権
   使用権の内容はお客様が購入又は入手された許諾プログラムの種類により異なります。お客様はパッケージに表記された種類に従い、以下の使用権の内容を遵守して下さい。
・RMDesignerの場合
  お客様は、許諾プログラムを機械読取可能な形で、特定の１台のコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途ＭＳＪより取得しなければなりません。
・RMViewer－C/Sの場合
  お客様は、許諾プログラムを機械読取可能な形で、お客様が購入したユーザ数分を同時にコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途ＭＳＪより取得しなければなりません。
・RMViewer－Webの場合
  お客様は、許諾プログラムを機械読取可能な形で、サーバ単位で使用することができます。
・RMViewer－RichClientの場合
    お客様は、許諾プログラムを機械読取可能な形で、サーバ単位又は、お客様が購入したユーザ数分を同時にコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。ユーザ数の場合は、Magic RichClient Server と同じユーザ数分の使用権をＭＳＪより取得しなければなりません。Magic RichClient Serverのシステムのみで使用することができます。
・体験版の場合
  お客様は、試用目的でだけ許諾プログラムを使用することができます。許諾プログラム、及び許諾プログラムを利用して開発したモジュールを営利目的に使用することはできません。
4. | 制限
   お客様は、以下の行為をしてはならないものとします。（但し、MSJによる書面による同意がある場合は、この限りではありません。）
(1) 許諾プログラムあるいはその使用権の譲渡、移転、または再使用権の設定を行うこと。
(2) 許諾プログラムあるいはその使用権をレンタル、リースまたは貸与すること。
(3) 許諾プログラムを改変、リバースエンジニアリングまたは逆アセンブルすること。
(4) 許諾プログラムの技術的な制限を回避する方法で利用すること。
(5) ＡＳＰやＳａａＳあるいはその他の方法で、第三者の業務処理目的で許諾プログラムを当該第三者に使用させること。(商用ホスティングサービスを含む)
5. | 許諾プログラム等の複製
   (1) お客様は、許諾プログラムの複製物を作成してはなりません。但し、バックアップを目的とする場合に限り、機械読取可能な形で許諾プログラムの複製物を２部まで作成することができます。
(2) お客様は、許諾プログラムのすべての複製物に、許諾プログラムに付されている著作権表示およびその他の権利表示を付すものとします。
(3) お客様は、このパッケージの許諾プログラム以外の同封物の一部、または全部の複製物を作成する場合には、ＭＳＪの事前の許諾を得るものとします。
6. | ＭＳＪの保証の範囲
   (1) ＭＳＪは許諾プログラムがお客様の特定の使用目的に合致し、また、いかなる場合でもその実行に誤りがないことを保証するものではありません。但し、お客様が登録カードを返送し、かつお客様が許諾プログラムを通常の方法で使用している場合に限り、許諾プログラム購入の日から３箇月以内に指定プログラムの誤り（バグ）を修正したソフトウェア・プログラムが発表されたときには、その修正したソフトウェア・プログラムまたは修正したソフトウェア・プログラムに関する情報を提供します。これをもってＭＳＪの唯一の保証とします。
(2) ＭＳＪの責任は、第６条(1)項に規定された保証のみに限定されるものとし、許諾プログラムを使用することにより生じたいかなる損害についてもその責は負いません。
7. | 契約の解約
   ＭＳＪは、お客様が本契約に定める事項に違反したとき、またはお客様において本契約を継続しがたい重大な事由があるときは、お客様に対し、何らの事前の通知なしに直ちに本契約を解約できるものとします。
8. | 契約終了時の措置
   本契約が第７条により解約された場合またはその他の事由により本契約が終了した場合、お客様は本契約が終了した日より１０日以内にインストールされた許諾プログラムのデータ及び許諾プログラムを格納した媒体並びにそれらの複製物を廃棄するものとします。
9. | 一般条項
   本契約のいずれかの条項またはその一部が法令により無効となった場合でも、その他の条項は、有効に存続するものとします。
10. | 準拠法および裁判管轄
   本契約は日本法に準拠するものとし、本契約に関する訴えは、東京地方裁判所をもって第一審の専属管轄裁判所とします。

マジックソフトウェア・ジャパン株式会社