ReportsMagic Version2.0a 追加情報

マジックソフトウェア・ジャパン株式会社
２０１６年４月

ReportsMagic Version2.1 追加情報

RMDesigner
RMViewer C/S
RMViewer Web
RMViewer RIA(RichClient)

本文書には､ReportsMagic Verison2.1 として提供されたプログラム に関して、マニュアルの記載事項以外の追加情報が記述されています。

  • 本バージョンのご利用にあたって [image] 　ご使用前に必ずお読みください。
  • サンプルフォーム、アプリケーション（RMDesigner）
  • サンプルフォーム（RMViewer Web版／RIA版）
  • V2.1の新機能
  • V2.1の改善・変更内容
  • 制限事項及び留意事項
  • 参考技術情報
  • 付録
    各種リンク情報
    ベータ版評価レポートのお願い
    製品構成
    動作環境
    ＦＡＱ
    使用許諾契約

本バージョンのご利用にあたって

バージョン表記

「ReportsMagicのバージョン情報」のバージョン表記は下記のようになっています。

モジュール | バージョン表示 | 製品バージョン※
RMDesigner.exe | Version 2.1 | 2.1.20.3
RMViewer.exe | Version 2.1 | 2.1.20.3
RMViewerCtrl.ocx (RMViewerActiveX.cab) | Version 2.1 | 2.1.20.3

※ファイルに組み込まれた製品バージョンです。 　HTML codebaseで指定する場合は、version=2,1,20,3と表現します。（カンマを使用）

ベータ版、体験版をご利用になったお客様に

ベータ版、体験版から製品版に移行する場合には、以下の点にご留意ください。

  • 本製品版をインストールするにあたりましては、ベータ版、体験版のモジュールが残って思わぬ悪影響を与えることを避けるため、ベータ版、体験版のアンインストールを行い、ファイル等の設定を完全に削除してください。
  • ベータ版、体験版で作成したフォームデータは、製品版で使用することはできません。

インストーラの変更　プログラム／サンプルフォルダの分離

Windows Vista／7／8／10／2008／2012の、セキュリティ強化機能（UAC（User Account Control））等の対応を考慮し、 プログラムフォルダとサンプルフォルダを分離してインストールできるようになりました。
デフォルトでは、同一フォルダ上（Program Files上）にインストールされますが、必要に応じてサンプルフォルダは、Program Files以外のフォルダを選択してインストールしてください。

インストールOS | デフォルト－プログラムインストールフォルダ | デフォルト－サンプルインストールフォルダ
Windows 7／８／10 2003／2008／2012 | C:\Program Files (x86)\ReportsMagicV2\RMDesigner | C:\Program Files (x86)\ReportsMagicV2\RMDesigner\Sample

  • 上記は、RMDesignerの場合です。

  • 旧バージョンからアップデートした場合は、既存フォルダ構成でアップデートを行います。

RMViewer（ActiveX)のCLSIDの変更

ReportsMagic V1.xとReportsMagic V2.xが、同一PC環境で共存できる様に、CLSIDを変更しました。

 | V1.x | V2.x
ActiveX CLSID | AAA3475B-DC7E-4C29-A719-08407FA18945 | D1DDC7EF-52D9-4750-A00F-4022F84B0586

RMViewer（ActiveX）のCAB化

Vre1.4で最新のOS環境でもRMViewer（ActiveX)の自動登録ができるようにRMViewerCtl.ocx をRMViewerActiveX.cabとCAB化 しましたが、Ver2.1ではインプリメント方法の変更によりCAB化は不要となりました。　CABファイルは、旧バージョンとの互換性の為に提供されています。

   HTMLの記述方法
OCX
RMViewerCtl.ocx 		<object classid="clsid:D1DDC7EF-52D9-4750-A00F-4022F84B0586" id="RMViewer"
codebase="http://localhost/RMViewerCtrl.cab#version=2,1,20,3"　width="100%" height="100%">
CAB
RMViewerActiveX.cab 		<object classid="clsid:D1DDC7EF-52D9-4750-A00F-4022F84B0586" id="RMViewer"
codebase="http://localhost/RMViewerActiveX.cab#version=2,1,20,3"　width="100%" height="100%">

RMViewer（ActiveX)のアップデート

メンテナンス処理、アップグレード処理で RMViewer（ActiveX)の再登録を実行した場合、「RMViewer体験版のご案内」、「RMViewerCtl.ocx の DllRegisterServerは成功しました」等のダイアログが表示される場合があります。その場合は、Enterを入力してそのまま継続してください。

過去のバージョンとの互換性

RMDesignerで作成されるフォームは、バージョン番号により管理されています。
基本的にフォームファイルは、上位互換性を持ちますが、下位互換性はサポートされていません。 旧フォームファイルを開き、書込みを行うと自動的に新バージョンへ移行しますので、事前にバックアップすることをお薦めいたします。

旧バージョンのフォームの移行

RMDesignerで旧バージョンのフォームを読み込むと自動的に、最新バージョンのフォームへ移行されます。
以下のようなダイアログが表示されます。

フォームの上位互換

フォームの上位互換は以下のようになっています。

RMViewer |  | フォームをオープンするRMViewerのバージョン
 |  | V1.0 | V1.1 | V1.2 | V1.3 | V1.3a/V1.3b | V1.4 | V2.0 | V2.1
フォームが作成されたバージョン | V1.0 | ○ | ○ | ○ | × | × | × | × | ×
 | V1.1 | × | ○ | ○ | × | × | × | × | ×
 | V1.2 | × | × | ○ | × | × | × | × | ×
 | V1.3 | × | × | × | ○ | ○ | ○ | × | ×
 | V1.3a/V1.3b | × | × | × | × | ○ | ○ | × | ×
 | V1.4 | × | × | × | × | × | ○ | × | ×
 | V2.0 | × | × | × | × | × | × | ○ | ○
 | V2.1 | × | × | × | × | × | × | × | ○

RMViewer V1.3bは、V1.3aとフォーム バージョンが同一です。RMViewer V1.3bは、V1.3、V1.3a/V1.3bのフォームのみサポートされ ます。

RMViewer フラットファイル |  | フラットファルをオープンするRMViewerのバージョン
 |  | V1.0 | V1.1 | V1.2 | V1.3 | V1.3a/V1.3b | V1.4 | V2.0 | V2.1
フラットファルが作成されたバージョン | V1.0 | － | － | － | － | － | － | － | ×
 | V1.1 | － | ○ | ○ | × | × | × | × | ×
 | V1.2 | － | × | ○ | × | × | × | × | ×
 | V1.3 | － | × | × | ○ | ○ | ○ | × | ×
 | V1.3a/V1.3b | － | × | × | × | ○ | ○ | × | ×
 | V1.4 | － | × | × | × | × | ○ | × | ×
 | V2.0 | － | × | × | × | × | × | ○ | ○
 | V2.1 | × | × | × | × | × | × | × | ○

フラットファイルはV1.1からサポート。

RMDesigner |  | フォームをオープンするRMDesignerのバージョン
 |  | V1.0 | V1.1 | V1.2 | V1.3 | V1.3a/V1.3b | V1.4 | V2.0 | V2.1
フォームが作成されたバージョン | V1.0 | ○ | ○ | ○ | △※1 | △※1 | △※1 | △※1 | △※1
 | V1.1 | × | ○ | ○ | △※1 | △※1 | △※1 | △※1 | △※1
 | V1.2 | × | × | ○ | △※1 | △※1 | △※1 | △※1 | △※1
 | V1.3 | × | × | × | ○ | △※1 | △※1 | △※1 | △※1
 | V1.3a/V1.3b | × | × | × | × | ○ | △※1 | △※1 | △※1
 | V1.4 | × | × | × | × | × | ○ | △※1 | △※1
 | V2.0 | × | × | × | × | × | × | ○ | △※1
 | V2.1 | × | × | × | × | × | × | × | ○

※1：旧フォームを開くことは可能ですが、旧バージョンのフォームを修正することはできません。　新バージョンへ移行する必要があります。

ReportsMagic修正履歴

ReportsMagicの修正履歴は、別ファイル（RevisionHistory.chm）に記述されています。　RMDesignerのみに添付されています。

ベータ機能／ご意見、要望事項について

提供するプログラム機能の一部が、ベータ機能として提供される場合があります。これらの機能はマジックソフトウェアジャパンのサポートセンターでのサポート対象外となります。
又、ご意見、ご質問、気が付いた点などは、「ベータ 機能評価レポート」に記入して、メールにて japan_mgxpa_beta@magicsoftware.com までお送りください。製品の改善に反映させていただきたいと思います。 お送りいただいたメールはすべて良く検討し、製品改善のための参考にさせていただきますが、お問い合わせの内容に対し個別にはお答えできない場合もありますので、予めご了承願います。

サンプルフォーム、アプリケーション（RMDesigner）

各種サンプルフォーム、及びMagicアプリケーションが提供されています。

RMDesigner／RMViewerでの確認

  • RMDesigner.exeを起動し 該当のフォームを開き、ツール／テストでサンプルデータを選択します。
  • RMViewer.exeを起動し 該当のフォームを開き、データ読込みでサンプルデータを選択します。
サンプルフォーム | フォーム名 インストールフォルダ\Sample\RMdataV21 | サンプルデータ インストールフォルダ\Sample\RMdataV21 | 備考
家族構成 （マルチデータフォーム） | EmpfamilyCsv.rfr | EmpfamilyCsv.csv | CSV形式
 | EmpfamilyCsvhead.rfr | EmpfamilyCsvhead.csv EmpfamilyCsvheadUTF-8.csv EmpfamilyCsvheadUTF-8BOM.csv EmpfamilyCsvheadUTF-16BOM.csv EmpfamilyCsvheadUTF-16BOMBig.csv | CSVヘッダー付き形式 文字コードパターン ・SJIS ・UTF-8 ・UTF-8BOM付き ・UTF-16 ・UTF-16 ビッグエンディアン
 | EmpfamilydbFORM.rfr | EmpfamilydbForm.dat | dbFORM形式
 | EmpfamilyXml.rfr | Empfamily.xml EmpfamilyUTF-8BOM.xml EmpfamilyUTF-16BOM.xml EmpfamilyUTF-16BOMBig.xml | XML形式 文字コードパターン ・SJIS ・UTF-8 ・UTF-16 ・UTF-16 ビッグエンディアン
家族構成一覧 | EmpfamilyList.rfr | EmpfamilyList.xml | XML形式 レイヤ関数使用 固定データ動的処理を使用
勘定科目名 （dbFORMからの移行） | HIKAKU.ｒｆｒ | HIKAKU.dat | dbFORMのフォームを読み込んで作成したものです。
 | HIKAKU.FRM | HIKAKU.dat | オリジナルのdbFORMのフォームです。新規フォームを作成し、「ファイル／dbFORM読み込み 」で 読み込むことができます。その後、「ツール／帳票設定」のデータ形式をdbFORM形式にして、確認します。
複合文書 | Fukugo.rfr （Fukugo.rff） | Fukugo.xml | 納品書、請求書、納品受領書の複合文書です。 ・CSV形式対応 ･イメージ透過（印影）
 | FukugoCSV.rfr | Fukugo.csv
複数ページ | Fukusu.rfr （Fukusu.rff） | Fukusu.xml Fukusu1740.xml Fukusu1000.xml Fukusu500.xml Fukusu100.xml | 暗黙の改ページのサンプルです。
複数テーブル | MtblFukusu.rfr | MtblFukusu.xml | 複数テーブルのサンプルです。
 | MtblFukusu2.rfr | MtblFukusu2.xml
バーコード | バーコード.rfr | バーコード.xml | バーコードの一覧表です。
イメージ | イメージ.rfr | イメージ.xml | イメージ処理のサンプルです。
ヒサゴ GB1101-納品書 (罫線無） | GB1101-納品書(罫線無）.rfr | GB1101納品書.xml | ヒサゴ GB1101-納品書(罫線無） プレプリントへの印刷を想定。納品書のイメージをスキャナー読み込みし、項目の位置合わせをしています。
ヒサゴ GB1101-納品書 (罫線有） | GB1101-納品書(罫線有）.rfr | GB1101納品書.xml | ヒサゴ GB1101-納品書(罫線有） ヒサゴのフォーマットに合わせて罫線等をReportsMagicで作成しています。
扶養控除等申告書 | 扶養控除等申告書（H18).rfr | 扶養控除等申告書（H18).xml |
保険料控除等申告書 | 保険料控除等申告書(H17).rfr | 保険料控除等申告書(H17).xml |
ブレーク処理 納品書 | BrNouhin1.rfr | BrNouhin.xml | 納品書ブレーク処理 ブレーク項目（日付、伝票番号）
 | BrNouhin1CSV.rfr | BrNouhin.csv | 納品書ブレーク処理 CSV形式 ブレーク項目（日付、伝票番号） ページブレーク(ユーザ名）毎ページ数の追加
 | BrNouhin2.rfr | BrNouhin.xml | 納品書ブレーク処理 1レコード 複数行表示レイアウト ブレーク項目（日付、伝票番号）
 | GrNouhin.rfr | GrNouhin.xml | 納品書グループ印刷 日付／伝票番号／品番・品名 で同一データが続いた場合は、「省略文字」を印字
演算子処理 | 演算子処理.rfr | 演算子処理.xml | 演算子処理 文字列操作の関数追加
言語変換 | EmpfamilyXml.rfr | Empfamily.xml | 言語変換ファイル「家族構成English.mls」を使用します。 日本語が英語になります。
文字列ライン | SetTextLine.rfr | SetTextLine.xml | 文字列ライン指定関数（SetTextLine）のサンプル
フォント、外字組込み | EmpfamilyXmlFont.rfr Empfamily衡山毛筆.rff | Empfamily.xml | 使用したフォントは、Fontフォルダに格納されています。（衡山毛筆フォント行書.ttf） Empfamily衡山毛筆.rff は、フォント、及び外字を組込だフラットファイルです。 上記のフォント、外字を組み込まなくても表示することが可能です。
商品一覧 | Product.rfr | Product.xml | テーブルにイメージ／バーコードを追加 ・@if 文字型比較、@Update
払込収納票 | 払込収納票.rfr | 払込収納票.xml | 払込収納票（標準料金代理収納使用）のサンプル @MIDを使用した、フォーマット変更を行っています。
ラベル | Label.rfr | Label.xml | ラベル(2×6 3×8）

デフォルトのインストールでは、C:\Program Files\ReportsMagicV2\RMDesigner\Sample\RMdataV21にフォームファイルが存在します。

メニューでの起動

Windows の「スタート」ボタンより、「プログラム(P)」→「ReportsMagicV2 RMDesigner」→ 「サンプル」から起動することができます。

メニュー名 | フォーム名 RMdataV14\ | 印刷データ RMdataV14\ | 備考
Magic xpa 3.xの起動 |  |  | Magic xpa 3.xのサンプルアプリケーション起動
Magic xpa 2.xの起動 |  |  | Magic xpa 2.xのサンプルアプリケーション起動
uniPaaS V1Plusの起動 |  |  | uniPaaS V1Plusのサンプルアプリケーション起動
バーコード | バーコード.rfr | バーコード.xml | XML形式 A4縦 RMViewer.exe起動 バーコードの一覧表です。
ヒサゴGB1101-納品書(罫線無） | GB1101-納品書(罫線無）.rfr | GB1101納品書.xml | XML形式 A4縦 RMViewer.exe起動 プレプリントへの印刷を想定。納品書のイメージをスキャナー読み込みし、項目の位置合わせをしています。
ヒサゴGB1101-納品書(罫線有） | GB1101-納品書(罫線有）.rfr | GB1101納品書.xml | XML形式 A4縦 RMViewer.exe起動 ヒサゴのフォーマットに合わせて罫線等をReportsMagicで作成しています。
ラベル | Label.rfr | Label.xml | XML形式 A4縦 RMViewer.exe起動
演算子処理 | 演算子処理.rfr | 演算子処理.xml | XML形式 A4縦 RMViewer.exe起動 演算子処理
家族構成 | EmpfamilyXml.rfr | Empfamily.xml | XML形式 A4縦 RMViewer.exe起動
家族構成HTML | EmpfamilyXml.rfr | Empfamily.xml | XML形式 A4縦 ブラウザ起動
家族構成-フォント／外字組込み | EmpfamilyXmlFont.rff |  | XML形式 A4縦 RMViewer.exe起動 衡山毛筆フォント行書.ttf、外字を組込んだフラットファイル
家族構成一覧 | EmpfamilyList.rfr | EmpfamilyList.xml | XML形式 A4縦 RMViewer.exe起動
家族構成-言語変換 | EmpfamilyXml.rfr | Empfamily.xml | XML形式 A4縦 RMViewer.exe起動 言語変換ファイル「家族構成English.mls」を使用します。日本語が英語になります。
商品一覧 | Product.rfr | Product.xml | XML形式 A4縦 RMViewer.exe起動 テーブルにイメージ／バーコードを追加
納品書-ブレーク処理 | BrNouhin1.rfr | BrNouhin.xml | XML形式 A4縦 RMViewer.exe起動 納品書ブレーク処理 ブレーク項目（日付、伝票番号）
複合文書 | Fukugo.rfr | Fukugo.xml | XML形式 A4縦 RMViewer.exe起動 納品書、請求書、納品受領書の複合文書です。
複数テーブル | MtblFukusu.rfr | MtblFukusu.xml | XML形式 A4縦 RMViewer.exe起動 複数テーブルのサンプルです。
複数ページ | Fukusu.rfr | Fukusu.xml | XML形式 A4縦 RMViewer.exe起動 暗黙の改ページのサンプルです。
複数ページ-大量 | Fukusu.rfr | Fukusu1000.xml | XML形式 A4縦 RMViewer.exe起動 暗黙の改ページのサンプルです。 1000ページ
保険料控除等申告書 | 保険料控除等申告書(H17).rfr | 保険料控除等申告書(H17).xml | XML形式 A4縦 RMViewer.exe起動 印刷フォームイメージにデータ項目を貼り付けて作成

RMDesignerで添付しているRMViewerは体験版です。RMDesignerエンタープライズパックには、RMViewer製品版が添付されています。

HTMLの場合、フォーム、印刷データのパスをドライブ指定で記述していますが、URLに変更することも可能です。
ただし、運用時には、RMViewerライセンスに注意が必要です。　ライセンス等の製品構成に関しては、こちらを確認してください。

●例
<param name="RfrFile" value="http://localhost/ReportsMagic/RMdataV20/EmpfamilyXml.rfr">
<param name="RDataFile" value="http://localhost/ReportsMagic/RMdataV20/Empfamily.xml">
<param name="ToolBar" value="on">

Magicと連携したサンプル

V10／uniPaaS V1用のサンプルアプリケーションは提供していません。

Ｃ／Ｓ（Magic xpa）

家族構成のXMLフォーム（EmpfamilyXml.rfr）を使用したサンプルアプリケーションです。
プログラムリポジトリの「ReportsMagic サンプル-メイン」をＦ７で実行してください。

メニュー | 内容
DB作成 | メモリテーブルにデータベースを作成します。
印刷データ作成 | 作成されたDBを元に、印刷用のXMLデータ（EmpfamilyMagic.xml）を生成します。
Magic Viewer .NET | Magicから .NETコントロールを使用して ActiveX版 RMViewerを実行します。
Magic Viewer EXE | Magicから RMViewer.exe起動用DLLを使用してRMViewer.exeを実行します。 印刷範囲指定のパラメータが追加されました。 指定する場合は、プレビュー表示をNoにします。 フォントファイルの追加、レイヤ数の拡張
Magic Viewer EXE Cmd | Magicから RMViewer.exe起動用DLLを使用してRMViewer.exeを実行します。 RMViewerコマンドライン実行関数を使用しています。 印刷範囲指定のパラメータが追加されました。 指定する場合は、プレビュー表示をNoにします。
HTML Viewer | ブラウザから、RMViewerを実行します。 表示用のHTML（家族構成.htm）を生成し、オープンします。
RMCompSec | 圧縮・フラットファイルを作成します。 RMCompSec.DLL初期化を実行してから、圧縮・暗号化を実行します。
RMCompLink | 複数のフラットファイルを結合します。

リッチクライアント（Magic xpa）

プログラムリポジトリの「ReportsMagic サンプル-メイン」　公開名(RMMain）をＦ７で実行します。

メニュー | 内容
DB作成 | メモリテーブルにデータベースを作成します。
印刷データ作成 | 作成されたDBを元に、印刷用のXMLデータ（EmpfamilyMagic.xml）を生成します。
RC Viewer ActiveX | リッチクライアントのブラウザコントロールでRMViewer（ActiveX）を実行します。
RC Viewer EXE(http) | リッチクライアントから RMExeViewer.exe使用してRMViewer.exeを実行します。
GUI印刷 | Magic GUI印刷のデモです。 ①Magic GUI印刷から仮想プリンタドライバ経由で拡張フラットファイル生成後、ブラウザコントロール（RMViewer）で表示します。 ②Magic GUI印刷からPDF出力後、ブラウザコントロール（PDF Reader）で表示します。
GUI印刷 イメージ変換 | Magic GUI印刷 イメージ変換のデモです。 ①Magic GUI印刷から仮想プリンタドライバ経由で拡張フラットファイル生成します。 ②拡張フラットファイルをイメージに変換します。 ③イメージファイルのインデックを取り込み、イメージを表示します。
RC Viewer .NET | Magicから .NETコントロールを使用して ActiveX版 RMViewerを実行します。
大量印刷 | 大量印刷デモです。 フラットファイルを使用した方法とPDFを使用した方法が提供されています。 ①フラットファイル生成後、ブラウザコントロール（RMViewer）で表示します。 RMCompSec.DLL初期化を実行してから、圧縮・暗号化を実行します。 ②RMViewerからPDF出力後、ブラウザコントロール（PDF Reader）で表示します。 フォント組込のパラメータが追加されました。

サンプルプログラムは、構造をシンプルにしていますが、実務で使用するには以下のような考量が必要です。

  • マルチユーザに関しては、対応していません。 (印刷データ、HTML名、プリンター名等）
  • 大量印刷の印刷用データ(XML)は固定データです。 （動的に生成はしていません）
    100、500、1000、1740ページ、（Fukusu100.xml、Fukusu500.xml、Fukusu1000.xml、Fukusu1740.xml）が準備されています。
  • PDF出力をリッチクライアントタスクで実行しています。
    大量印刷のような長時間のバッチ処理が想定される場合は、バッチタスク（並行実行、又はMagic Enterprise Serverによりコールリモート）で処理する必要があります。
  • サンプルでは、理解しやすくする為フォームファイル名、データファイル名でDBCSを使用していますが、 リッチクライアント／Webアプリケーションで使用する場合は、半角英数字のみを使用することをお奨めいたします。
  • Adobe Reader 9以上を使用するとリッチクライアント終了時に「uniRC.exe　アプリケーション エラー」が発生する場合があります。（Adobe Readerの制限）

リッチクライアントの環境設定

リッチクライアントのサンプルを使用する場合に設定します。

インターネット インフォメーション サービス(IIS)

IISがインストールされた環境では、インストーラが自動設定します。

  • 仮想ディレクトリを設定します。

    ReportsMagic21Sample C:\Program Files\ReportsMagicV2\RMDesigner\Sample\RMdataV21

  • MIMEの追加
    拡張子 | MIMEの種類
    rff | application/ReportsMagic-flatfile
    rfr | application/ReportsMagic-formfile

    上記の拡張子以外を使用する場合は、必要に応じて追加してください。　ReportsMagicファイル形式一覧 参照。

印刷関連

  • PDF出力には、「PDFファイルを出力するソフト」が必要になります。
    PDFは、決められたフォルダ内に自動出力でき、PDF生成後に結果表示をしない機能が必要です。　（テスト的に手作業でフォルダ指定等を行うようにすれば可能です。）
    事前にPDF出力フォルダを作成してください。（デフォルトは、C:\PDF）
    又、PDFのプリンター名を設定します。
  • 仮想プリンタドライバをインストールし、上記と同様に設定します。

環境設定

  • 論理名を必要に応じて修正します。（殆どはインストーラが自動設定します。）

C:\Program Files\ReportsMagicV2\RMDesigner\Sample\xpa3\RMinixpa3.ini ← Magic xpa 3.x

C:\Program Files\ReportsMagicV2\RMDesigner\Sample\xpa\RMinixpa.ini ← Magic xpa 2.x

C:\Program Files\ReportsMagicV2\RMDesigner\Sample\uniPaaSV1Plus\RMiniV1plus.ini ← uniPaaS V1Plus

/[MAGIC_ENV]ActivateRequestsServer=Y
/[MAGIC_ENV]DefaultProject = *C:\PROGRA~2\REPORT~1\RMDESI~1\Sample\xpa\ReportsMagic.edp
/[MAGIC_ENV]DefaultProject = *C:\PROGRA~2\REPORT~1\RMDESI~1\Sample\xpa\ReportsMagic.edp
/[MAGIC_ENV]RuntimeApplicationFontDefinitionFile = *C:\PROGRA~2\REPORT~1\RMDESI~1\Sample\xpa\fnt_rnt.jpn
/[MAGIC_ENV]RuntimeApplicationColorDefinitionFile = *C:\PROGRA~2\REPORT~1\RMDESI~1\Sample\xpa\clr_rnt.jpn
/[MAGIC_LOGICAL_NAMES]RM_SampData = *C:\PROGRA~2\REPORT~1\RMDESI~1\Sample\RMDATA~1\
/[MAGIC_LOGICAL_NAMES]RM_SampMagic = *C:\PROGRA~2\REPORT~1\RMDESI~1\Sample\xpa\
/[MAGIC_LOGICAL_NAMES]RM_Root = *C:\PROGRA~2\REPORT~1\RMDESI~1\			←ReportsMagic インストールフォルダ
/[MAGIC_LOGICAL_NAMES]RM_PDF = *C:\PDF\					←PDF出力フォルダ名
/[MAGIC_LOGICAL_NAMES]RM_URLRoot = *http://localhost/ReportsMagic20Sample/	←仮想ディレクトリ名
/[MAGIC_LOGICAL_NAMES]RM_ExePass = *C:\PROGRA~2\REPORT~1\RMDESI~1		←RMExeViewer.exe格納フォルダパス（最後に\は不要）
/[MAGIC_LOGICAL_NAMES]RM_PDFPrinterName = Bullzip PDF Printer			←PDF出力プリンター名
/[MAGIC_LOGICAL_NAMES]RM_EFlatPrinterName = RM Printer2
/[MAGIC_LOGICAL_NAMES]RM_OutFile_Nmae = Output.PDF

/[MAGIC_PRINTERS]RM_PDF =Bullzip PDF Printer,SUPPORT\WPDRV.ATR,,60
/[MAGIC_PRINTERS]RM_FLAT =RM Printer2,SUPPORT\WPDRV.ATR,,60

/[dbMAGIC_ENV]NoDocumentName = Y

  • RMViewer表示した時にフォームファイルまたは、フラットファイルの読み込みができない場合には、MIMEの設定を確認してください。
  • 参考：「Magic xpa Web／RIAにおけるRMViewerの実装、配布」

Bullzip PDF Printerの設定例

PDF生成ソフトウェア（仮想プリンタードライバ）としてフリーソフトのBullzip PDF Printerの設定例を示します。　しかし、MSJが動作を保証したり、推奨するものではありません。 特に、運用環境に於いては有償のPDFソフトウェアを使用することを強く推奨致します。

出力フォーマット、ファイル名等を設定します。

ダイアログ表示を、「しない」にします。

サンプルフォーム（RMViewer Web版／RIA版）

RMViewer Web版、RIA版のサンプル

インストーラは、IIS環境がある場合、IISの仮想ディレクトリの設定を行います。

RMDesignerのサンプルのHTML（ブラウザ）のデモは、ファイルアクセスで行っています。

製品 | URL
RMViewer Web版 | http://ホスト名/ReportsMagic21/ReportsMagicWeb.html
RMViewer RichClient版 | http://ホスト名/ReportsMagic21/ReportsMagicRC.html

  • Web版とRIA版の違いは、RIA版には「RMViewer exe版のダウンロード」が提供されています。


ReportsMagic Ver2.0a 修正履歴

V2.1の新機能

CSV形式のマルチフォーム対応

CSV形式のフォーマットで、マルチフォームに対応できるよう になりました。

帳票設定において、フォーム番号を指定するデータ項目を指定します。CSV形式の場合は、番号指定（例：%%3）、ヘッダー付きCSV形式の場合は、 「データ項目名」を指定します。（例： FNO）

CSV印刷データ・フォーマット

ヘッダー付きCSV形式の場合は、先頭で全フォーム番号順にフォーマットを定義します。 以下の例は、同一フォーマット形式になっていますが、異なったフォーマットでも問題ありません。

CSVデータ・フォーマット | 備考
"FNO","PNO","住所１","住所２","ユーザ名","担当者","納品日","合計金額","消費税","作成日","時刻","品番・品名",・・・・ "FNO","PNO","住所１","住所２","ユーザ名","担当者","納品日","合計金額","消費税","作成日","時刻","品番・品名",・・・・ "FNO","PNO","住所１","住所２","ユーザ名","担当者","納品日","合計金額","消費税","作成日","時刻","品番・品名",・・・・ | 各フォーム毎にヘッダーを指定
"1","05010100001","東京都港区六本木１－１－１","山田ビル３Ｆ","山田 太郎","マジック太郎","20041225","99999999",・・・・ "1","05010100001","東京都港区六本木１－１－１","山田ビル３Ｆ","山田 太郎","マジック太郎","20041225","99999999",・・・・ "1","05010100001","東京都港区六本木１－１－１","山田ビル３Ｆ","山田 太郎","マジック太郎","20041225","99999999",・・・・ | フォーム１
"2","05010100001","東京都港区六本木１－１－１","山田ビル３Ｆ","山田 太郎","マジック太郎","20041225","99999999",・・・・ "2","05010100001","東京都港区六本木１－１－１","山田ビル３Ｆ","山田 太郎","マジック太郎","20041225","99999999",・・・・ "2","05010100001","東京都港区六本木１－１－１","山田ビル３Ｆ","山田 太郎","マジック太郎","20041225","99999999",・・・・ | フォーム２
"3","05010100001","東京都港区六本木１－１－１","山田ビル３Ｆ","山田 太郎","マジック太郎","20041225","99999999",・・・・ "3","05010100001","東京都港区六本木１－１－１","山田ビル３Ｆ","山田 太郎","マジック太郎","20041225","99999999",・・・・ "3","05010100001","東京都港区六本木１－１－１","山田ビル３Ｆ","山田 太郎","マジック太郎","20041225","99999999",・・・・ | フォーム３

データ・フォーマット上のフォーム番号（上記例ではFNO)は、フォームのページNOを指定します。

  • マルチフォームのヘッダー付きCSVのサンプルは、サンプルフォーム（FukugoCSV.rfr）が提供されています。

イメージの透過サポート

イメージの透過がサポートされるようになりました。　ただし、データ項目のみが対象となります。　固定項目では対応できません。

  • サンプルフォーム（Fukugo.rfr/FukugoCSV.rfr）で使用しています。

RMViewer 機能拡張

文字列検索の対応

プレビュー画面での文字列検索に対応しました。

PageUp/PageDownキーでのスクロール対応

プレビュー画面での、PageUp/PageDownキーでスクロールできるようになりました。

RMPrinter 論理プリンタ作成

複数の論理プリンタ作成に対応しました。

  • 詳細は、RMPrinterのReadmeを参照してください。

RMPrinter サブフォルダ指定

ドキュメント名でサブフォルダを指定できるようになりました。
Magicの入出力ファイルの「名前」欄に'\'より前が出力先のサブフォルダを指定します。

（例）
プリンタドライバのプロパティの出力先がC:\PDF、入出力ファイルの「名前」欄が'TEST\Sample'の場合
C:\PDF\TESTフォルダにSample.rffが作成されます。

  • サブフォルダは作成されませんので、事前に作成しておく必要があります。
  • 詳細は、RMPrinterのReadmeを参照してください。

V2.1の改善・変更内容

RMDesigner

  • ラベル印刷フォームで、項目のプロパティのオペランド一覧をクリックすると、異常終了する問題に対応しました。（1000304）

RMDesigner/RMViewer共通

  • ラベル印刷フォームに固定項目があり、データ項目にオペランドが設定している場合、テスト表示または、RMViewerを実行すると、異常終了する問題に対応しました。（1000305）
  • プロポーシャナルフォントで文字ピッチを0に設定した場合、文字列枠の途中で改行される問題に対応しました。（1000318）
  • 文字ピッチを0に設定した場合、１行分文字列枠を超えて表示される問題に対応しました。（1000319）
  • バーコード標準料金代理収納で異常終了する場合がある問題に対応しました。（1000343）

RMViewer共通

  • dbFORM形式の場合、ビュア表示から印刷できない問題に対応しました。（1000298）
  • /prnパラメータで用紙サイズ指定すると、フォームの用紙サイズと異なる場合、正しく印刷されない問題に対応しました。（1000299）
  • RMViewerをバックグランド(/dsp=n）で連続して印刷すると、「Runtime Error」が発生し、印刷できない場合がある問題に対応しました。（1000301）
  • 「サイズ」指定で、'用紙合わせる'または、'大きなサイズ'を縮小した場合、/prnパラメータで指定したオフセットサイズより大きくずれて印字される問題に対応しました。（1000303）
  • イメージファイルのあるフォームをRMPrinetrに印刷した拡張FLATファイルをRMViererでプレビューすると、メモリ不足でファイルが開けないことがある問題に対応しました。（1000321）
  • 拡張FLATファイルを「起動ページ番号」パラメータを指定しても１ページ目が表示される問題に対応しました。（1000322）
  • 帳票設定/実行時設定の「フォームファイルのページサイズに合わせて用紙選択」欄をチェックしているフォームを/pagefitパラメータが有効にならない問題に対応しました。（1000323）

RMViewer AxtiveX版

  • IEで実行されたActiveX版から印刷すると稀にフリーズする場合ある問題に対応しました。（1000296）

RMPrinter

  • RMPrinterインストールの終了時に、「スプールが開始できません．」のエラーが発生する問題に対応しました。（1000291）
  • RMPrinterのプロパティで、起動ページ番号が不定値になる場合がある問題に対応しました。（1000292）
  • Magicの入出力ファイルの「名前」欄が空欄の場合、RMPrinterに印刷すると、Windowsのスプーラが異常終了する問題に対応しました。（1000295）

Ver2.1(Boundle版)からの修正

  • RMViewerを単独で実行した場合、ツールバーのページ番号や拡大率が前回起動した値が設定されている問題に対応しました。（1000316）

  • ツールバーやステータスバーを非表示にした状態でRMViewerを終了した場合、ツールバーやステータスバーを表示指定でRMViewerを実行しても、ツールバーやステータスバーが表示されない問題に対応しました。（1000317）

マニュアル（Readme)の主な変更

  • V2.1の新機能
  • 制限事項及び留意事項
  • RMViewer 起動オプション
  • RMViewer ActiveX起動オプション
  • RMViewer 起動用DLL一覧


制限事項及び留意事項

イメージ

  • スタティックなイメージ読み込みは、イメージ形式によっては実際のイメージと異なる表示になる場合があります。
  • イメージをデータ項目として使用する場合、サポートしているイメージ形式は以下の種類です。
    BMP、PNG、JPEG、GIF
  • イメージのデータ項目の場合、イメージデータのサイズ比率を維持したままで、コントロール上に収まるように拡大/縮小します。

印刷

  • Windowsのプリンタドライバを使用しての印刷のみをサポートしています。
  • プリンタの内蔵フォントで印刷した場合には、ReportsMagicで表示されているフォントと印刷されるフォントが異なる場合があります。
    その場合は、プリンタのプロパティのフォントの設定をプリンタ内臓のフォントから TrueType フォントに変更します。TrueType フォントを使用する設定はプリンタの種類によって異なりますので、お使いのプリンタのマニュアルをご覧ください。

テーブル

  • テーブルのプロパティで列数を変更しても、列サイズをリサイズしません。 リサイズしたい場合は、RMDesigner.iniで、下記のパラメータを追加してください。
    [General-Summary]
    TableResize=Y

データ連携

  • テーブルの連結には、対応していません。
  • 複数テーブルの場合、暗黙の改ページはサポートされません。　明示的な改ページで作成します。
  • 複数テーブルの場合、テーブルの行数分の印刷データが存在しない場合は、空白のダミーデータを作成してください。
  • 複数テーブルの場合、異なる行数のテーブルを組合わせる場合は、行数が多いテーブルが最後になるように印刷データを生成してください。

データ項目ウインドウ

  • データ項目ウインドウを表示している状態で、フォーム上のデータ項目を削除しても、データ項目ウインドウには反映されません。その場合は、データ項目ウインドウの再表示を実行してください。
  • フォームに割り付けたデータ項目のプロパティを開いて項目名を変更した場合、新規に変更した項目が追加されます。 以前のデータ項目は、データ項目削除ダイアログで削除することができます。

フォーム作成

  • 縦文字を指定した場合、フォントは@が付いた縦書き用フォントを選択してください。縦書用フォントで無い場合は@MSゴシックを使用します。
  • テーブルをネストして使用することは出来ません。
  • フォーム作成時に稀に画面にゴミが表示される場合があります。　その場合は。再表示(Ｆ５）を行ってください。
  • 同一のデータ項目をフォーム上に複数配置した場合、オペランド欄を使用することはできません。

その他

  • 外字を使用する場合は、実行するPCに事前に外字を登録しておく必要があります。 （フラットファイルで外字を組み込んだ場合は除きます。）
  • 文字列を固定幅フォント－文字ピッチ０の状態で使用すると、解像度の異なるコンピュータで表示イメージが異なる場合があります。その場合は、文字ピッチを指定するようにしてください。
  • マルチフォーム（複合帳票）で異なる用紙サイズを組合わせることは、サポートされていません。

バーコード

  • 各バーコードの仕様に合わせたサイズになるようにフォームを調整してください。
  • プリンタ、用紙、リーダ、トナーの濃度などの組み合わせにより正しく読み取れない場合があるので、実際に使用される環境で十分テストを行うようにしてください。
  • 郵便カスタマーバーコードの詳細情報は、参考技術情報を参照してください。、

RMViewer

  • RMViewer（ActiveX)をMagicのバッチタスクで印刷することは出来ません。バッチタスクで印刷する場合は、RMViewer（EXE)を使用してください。
  • 同一のフォームを20回以上オープンすると「ドキュメントを開くことに失敗しました。」のエラーになります。　Terminal Services環境の場合は、特に注意が必要です。　この問題を回避するには、同じフォームを複数コピーしフォルダ／フォームファイル名を変更するか、フラットファイル化（ＲＦＦ）、フォームファイルの圧縮・暗号化（RFC）等が考えられます。
  • Magicサーバ製品（Magic xpa Enterprise Server、Magic xpa RIA Server等）をサービス起動している場合に、起動アカウントが「ローカルシステムアカント」になっていると、プリンタから出力できない場合があります。 その場合は、MRBサービス、又は自動起動のエントリで、Administrator 等の権限のあるアカウントに変更してください。　参考：スキルアップセンター／Magic xpa サーバ構成「Magic xpaサーバから、ネットワークファイルをアクセスできますか？」

Unicode

  • サロゲート・ペア文字（4バイトのUnicode文字）については、対応していません。

.Netコントロール

  • Magic xpa 3.0のオンラインタスクで、ReportsMagicフォームを埋め込む場合、製品版とバンドル場合で使用するコンポーネント(RMVIEWERCTRLLib、AxRMVIEWERCTRLLib)が異なります。
    Magic xpaのコンポーネントリポジトリに、以下のフォルダのコンポーネントを指定してください。

    バンドル版の場合
    Magic xpa3.のインストールフォルダの’RMViewer’フォルダ

    製品版の場合
    Magic xpa3.のインストールフォルダの’ RMViewerDotNet’フォルダ、又はRMViewer(RMDesigner)のインストールフォルダ

既知の不具合

  • 図形のプロパティの座標でX,Y座標を変更後、基準点を変更した場合、 X,Y座標が変更前の座標で座標変換されている。
  • 図形のプロパティでは幅と高さを0に設定し、適用すると、以降、 幅と高さを0以外の設定しても幅と高さが0の状態で表示されてしまう。

セキュリティ

  • マイクロソフト セキュリティ情報 MS09-035 - 警告
    Visual Studio の ＡＴＬ（Active Template Library）の脆弱性により、リモートでコードが実行される (969706)
    件に関しては、ReportsMagicのActiveXは、ＡＴＬを使用していませんので該当しません。

仮想プリンタドライバ

  • 運用環境では、常にサーバ環境で拡張フラットファイルを作成するようにします。 つまり、サーバ製品（RMViewer Web、RMViewer RichClient） の場合は、そのままサーバ環境で仮想プリンタドライブ作成するようにします。 クライアント製品（RMViewer C/S）の場合は、ネットワークプリンタ機能でサーバ上の仮想プリンタドライバを使用するようにします。
  • 一部のイメージが出力されない場合があります。
  • 理論的には、Windwosアプリケーション全般で使用することが可能ですが、正式サポートは、Magic GUI印刷で使用した場合のみとなります。

サポート環境

  • Windows Terminal Server、Citrix XenAppでの使用は、サポート対象外となります。
  • 仮想環境（Hyper-V、VMWare など）上で、ReportsMagicは実環境同様に動作しますが、仮想環境での動作を保証するものではありません。 仮想環境固有の問題についてはサポートできません。

dbFORM

  • dbFORMのフォームを読み込んだ場合、若干フォームイメージが異なる場合があります。
  • dbFORMのフォームを読み込んだ場合、データや罫線等の一部がスキャナレイヤに割りあたっている場合があります。その場合は、他のレイヤに変更してください。　尚、デフォルトではスキャナレイヤは「選択不可」になっていますので、一度「選択可」にしてください。
  • 文字単位のフォント指定、属性指定は、できません。
  • 文字の囲み、傍点、袋文字、影付き、立体、下付、上付はサポートされていません。
  • バーコードはサポートされていません。
  • 縦書きの場合、１バイト文字は縦書きになりません。
       dbFORM形式は、既存フォームの移行を主目的としており、ReportsMagicの新機能サポート、今後の機能拡張の計画はありません。
既存フォームを取り込んだあとは、CSV、XML形式に移行されることを推奨いたします。


ReportsMagic 参考技術情報

参考技術情報

ここでは、ReportsMagic についての参考技術情報を紹介します。

  • RMViewer 起動オプション
  • RMViewer ActiveX起動オプション
  • RMViewer 起動用DLL一覧
  • 圧縮・暗号化 フラットファイルDLL一覧
  • RMViewer C/S版とWeb版のアクセス
  • ショートカットキー一覧
  • 「帳票設定」で指定した用紙サイズ、給紙方法や部数の対応
  • RMViewer ActiveX版（RMViewerCtrl.ocx）の登録について
  • 文字列の出力可能範囲について
  • XML形式で文字列の前に半角スペースは有効にならない
  • 「セキュリティ保護の為コンピュータにアクセスできるアクティブコンテンツは表示されないよう、Ｉnternet Explorerで制限されています。オプションを表示するには、ここをクリックしてください...」
  • データ連携－データ形式の違い
  • ReportsMagicファイル形式一覧
  • RMCompSec.DLLのエラーコード一覧
  • RMViewer 起動用DLL-RMViewer.DLLのエラーコード一覧
  • CSV（Comma-Separated Values）
  • バーコード
  • Magic xpa Web／RIAにおけるRMViewerの実装、配布

RMViewer 起動オプション

表示方法 | 内 容
フォームファイルの指定 | /rfr=フォームファイル名
印刷データファイルの指定 | /rdata=データファイル名
プレビュー表示 | /dsp=[y|n] ‘y’ ･････プレビュー表示をします。 ‘n’ ･････プレビュー表示を行わず、すぐにバックグラウンドで印刷を開始します。
プリンタ名の指定 | /prn= …… 実行時に印刷プリンタを指定することが可能です。 プリンター名(，用紙サイズ，用紙の向き，供紙方法(，用紙の長さ，用紙の幅) )（/垂直オフセット，水平オフセット） 用紙の長さ，用紙の幅は、用紙サイズでユーザ定義を指定した場合のみ有効です。 （例） /prn=EPSON LP-9400 /prn=EPSON LP-9400，A4 210 × 297 mm，縦，用紙ﾄﾚｲ /prn=EPSON LP-9400，，，用紙ｶｾｯﾄ1 /prn=EPSON LP-9400，ﾕｰｻﾞｰ定義ｻｲｽﾞ，，，2000，1000 ※省略した場合は、各プリンターのデフォルト値
拡大率の指定 | /zoom= ‘10～500’の数字、または‘i’、‘w’、‘a’または ‘p’を指定します。 10から500の数字 ･････ 拡大率を表します。100が通常の倍率です。 ‘i’ ･････ 基準倍率表示（デフォルト） ‘w’ ･････ ウインドウの描画領域幅にページの横幅を合わせます。 ‘p’ ･････ ページ全体を表示します。（デフォルト） ウインドウの描画領域の縦幅にページの縦幅を合わせます。 ‘a’ ･････ 全画面表示を行います。
ページレイアウトの指定 | /pagelayout= 1,2,3のいずれかを指定します。 ‘1’ ･････1ページ表示を行います。（デフォルト） ‘2’ ･････連続１ページ表示を行います。 ‘3’ ･････連続２ページ表示を行います。
サムネール表示の指定 | /thumbnail= ‘y’ または ‘n’ を指定します。 ‘ｙ’ ･････サムネール表示を行います。 ‘n’ ･････サムネール表示を行いません。（デフォルト）
メニューバー表示の指定 | /menubar= ‘y’ または ‘n’を指定します。 ‘ｙ’ ･････メニューバーを表示します。（デフォルト） ‘n’ ･････メニューバーを表示しません。
ツールバー表示の指定 | /toolbar= ‘y’ または ‘n’ を指定します。 ‘y’ ･････ツールバーを表示します。（デフォルト） ‘n’ ･････ツールバーを表示しません。
ステータスバー表示の指定 | /statusbar= ‘y’ または ‘n’ を指定します。 ‘y’ ･････ステータスバーを表示します。（デフォルト） ‘n’ ･････ステータスバーを表示しません。
印刷部数の指定 | /copy=部数 印刷部数を指定します。 コピー処理は、プリンタドライバ側で処理しますので、コピー処理をサポートしていないプリンタドライバの場合は、無効になります。
印刷ステータスダイアログの指定 | /status= ‘y’ または ‘n’ を指定します。 ‘y’ ･････印刷ステータスダイアログを表示します。（デフォルト） ‘n’ ･････印刷ステータスダイアログを表示しません。
言語変換ファイルの指定 | /mls=パス名 （例） RMViewer.exe /rfr=XXX.RFF /dsp=y /mls=XXXX.MLS
レイヤ表示の指定 | /layer=レイヤパラメータ を指定します。 レイヤパラメータ： レイヤ１～７、スキャナ、OLE、オーバレイの順番で指定します。（1234567SOV） 0：非表示、1：表示、－：デフォルトのまま （例） RMViewer.exe /rfr=XXX.RFF /dsp=y /layer=1011100--- レイヤ１、３，４，５：表示、レイヤ２、６，７：非表示、スキャナ、OLE、オーバレイ：デフォルト表示 拡張パラメータ：レイヤ１～１２、スキャナ、OLE、オーバレイ（123456789012SOV）
印刷範囲指定 | /page=[開始ページ]-[終了ページ] （例） /page=5 5ページのみ /page=5- 5ページから最終ページ ※プレビュー表示がNoで無ければ有効になりません。
フォント組込ファイルの指定 | /rfn=フォント組込ファイル名
ページ拡大縮小 | /pagefit=0,1,2 0：用紙に合わせる,1：大きいページを縮小する,2：実際のサイズ
フォームファイルのページサイズに合わせて用紙選択 | /pagesize=’y’ または ‘n’を指定します。
用紙の向きを自動で選択 | /autodir=’y’ または ‘n’を指定します。

「帳票設定」のRMViewer初期オープンモードよりも、起動オプションの方が優先されます。

RMViewer ActiveX起動オプション

プロパティ一覧 | 内 容
Copy | コピー数 コピー処理は、プリンタドライバ側で処理しますので、コピー処理をサポートしていないプリンタドライバの場合は、無効になります。
PageLayout | ページレイアウト番号
PrinterName | プリンター名
RDataFile | 印刷データファイル名
RfrFile | フォームファイル名
RfnFile | フォント組込ファイル名
Zoom | 拡大率（'10-500','i','w','a','p'）
Thumbnail | サムネール表示 （'on','off'）
ToolBar | ツールバー表示 （'on','off'）
Mls | 言語変換ファイル名 言語変換ファイルの指定
Layer | レイヤ表示
PageFit | ページ拡大縮小
PageSize | フォームファイルのページサイズに合わせて用紙選択
AutoDirect | 用紙の向きを自動で選択

メソッド一覧 | 内 容
AboutBox | RMViewer バージョン情報
OnThumbnail | サムネール表示
OnToolBar | ツールバー表示
PageFirst | 先頭ページ
PageLast | 最終ページ
PageLayout1 | ページレイアウトの指定 1ページ表示
TPageLayout2 | ページレイアウトの指定 連続１ページ表示
PageLayout3 | ページレイアウトの指定 連続２ページ表示
PageNext | 次ページ
PagePre | 前ページ
PageSelect | 印刷範囲の指定
PrintData | 印刷
ZoomAll | 拡大率：ページ全体を表示
ZoomAllWidth | 拡大率：ウインドウの描画領域幅にページの横幅を合わせる
ZoomBase | 拡大率：基準倍率表示
ZoomFulll | 拡大率：全画面表示
ZoomIn | 拡大率：拡大
ZoomOut | 拡大率：縮小
ZoomArea | 領域表示

RMViewer 起動用DLL一覧

RMViewer.ExecuteXXX

パラメータ一覧 | パラメータ値 | 200 | 140 | 131 | 130 | 110 | なし
フォームファイル名（文字型） | ファイルパス | ① | ① | ① | ① | ① | ①
データファイル名（文字型） | ファイルパス | ② | ② | ② | ② | ② | ②
プリンタ名（文字型） | ファイルパス | ③※1 | ③※1 | ③※1 | ③ | ③ | ③
RMViewerの実行フォルダ（文字型） | フォルダパス | ④ | ④ | ④ | ④ | ④ | ④
プレビューあり/プレビューなし（文字型） | 'y'、'n' | ⑤ | ⑤ | ⑤ | ⑤ | ⑤ | ⑤
ウェイト指定（文字型） | 'y'、'n' | ⑥ | ⑥ | ⑥ | ⑥ | ⑥ | ⑥
印刷部数（文字型） |  | ⑦ | ⑦ | ⑦ | ⑦ | ⑦ | ⑦
印刷中表示画面の表示・非表示（文字型） | 'y'、'n' | ⑧ | ⑧ | ⑧ | ⑧ | ⑧ | ⑧
拡大率（文字型） | （‘10～500’、‘i’、‘w’、‘a’、‘p’） | ⑨ | ⑨ | ⑨ | ⑨ | ⑨ |
ページレイアウト（文字型） | （1,2,3） | ⑩ | ⑩ | ⑩ | ⑩ | ⑩ |
サムネール表示 （文字型） | 'y'、'n' | ⑪ | ⑪ | ⑪ | ⑪ | ⑪ |
メニューバー表示 （文字型） | 'y'、'n' | ⑫ | ⑫ | ⑫ | ⑫ | ⑫ |
ツールバー表示 （文字型） | 'y'、'n' | ⑬ | ⑬ | ⑬ | ⑬ | ⑬ |
ステータスバー表示（文字型） | 'y'、'n' | ⑭ | ⑭ | ⑭ | ⑭ | ⑭ |
言語変換ファイル名（文字型） | ファイルパス | ⑮ | ⑮ | ⑮ | ⑮ |  |
レイヤ表示の指定 （文字型） | レイヤ１～７(12)、スキャナ、OLE、オーバレイの順番で指定 ※2（1234567SOV） （123456789012SOV） | ⑯ | ⑯ | ⑯ | ⑯ |  |
印刷範囲指定（文字型） | [開始ページ]-[終了ページ] | ⑰ | ⑰ | ⑰ |  |  |
フォント組込ファイル（文字型） | ファイルパス | ⑱ | ⑱ |  |  |  |
ページの拡大/縮小 | 0：用紙に合わせる,1：大きいページを縮小する,2：実際のサイズ | ⑲ |  |  |  |  |
フォームファイルのページサイズに合わせて用紙選択 | 'y'、'n' | ⑳ |  |  |  |  |
向きを自動で選択 | 'y'、'n' | 21 |  |  |  |  |
実行結果のエラー番号（数値型） |  | 22 | ⑲ | ⑱ | ⑰ | ⑮ | ⑨
エラーメッセージ（文字型） |  | 23 | ⑳ | ⑲ | ⑱ | ⑯ | ⑩
  • 番号は、パラメータの順番を意味します。
  • ※1： 用紙サイズ、用紙の向き、給紙方法 、オフセットが指定可能。
     プリンタ名(/用紙サイズ，用紙の向き，給紙方法(，用紙の長さ，用紙の幅) )（    /垂直オフセット，水平オフセット）
  • ※2： 1～7、1～12は、桁数に応じて自動認識。

圧縮・暗号化 フラットファイル DLL一覧

パラメータ一覧 | パラメータ値 | RMCompSec.RMCS_EncodeX
 |  | 3 | 2 | なし
フォームファイル名（文字型） | ファイルパス | ① | ① | ①
印刷データファイル（文字型） | ファイルパス | ② | ② | ②
言語変換ファイル名（文字型） | ファイルパス | ③ | ③ |
フォント組込ファイル（文字型） | ファイルパス | ④ |  |
圧縮・暗号化ファイル（文字型） | ファイルパス | ⑤ | ④ | ③
オプション（文字型） | 0：RFC作成 1：XMC作成 2：CSC作成 3：RFF作成指示 5：RFC作成 イメージ組込 6：XMC作成 イメージ組込 7：CSC作成 イメージ組込 8：RFF作成指示 イメージ組込 | ⑥ | ⑤ | ④
パスワードオプション | 0：フォームファイルのパスワードを使用 1：無し 2：個別指定 | ⑦ | ⑥ | ⑤
パスワード（文字型） |  | ⑧ | ⑦ | ⑥
実行結果のエラー番号（数値型） |  | ⑨ | ⑧ | ⑦
エラーメッセージ（文字型） |  | ⑩ | ⑨ | ⑧
  • 番号は、パラメータの順番を意味します。
  • オプション5～6は、RMCompSec.RMCS_Encode3からサポート

RMCompSec.RMCS_Init
パラメータ：
パラメータ (入力引数:文字型)
戻り値 (戻り値:数値型)
エラーメッセージ (戻り値:文字型)

  • マルチスレッド環境で使用するには、RMCompSec.RMCS_Initのパラメータに以下を指定しします。
    /MultiThread=Y
  • RMViewer Web版、RMViewer RichClient版でのみ使用することができます。RMViewer C/S版（uniPaaS Client）の環境では、指定してもシングルスレッドとして動作します。
  • 使用するDLLは以下です。　Magicの環境に合わせてコピー等を行ってください。
    RMCompSec.dll、RMCompSec01.dll～RMCompSec05.dll

RMCompSec.RMCS_Term
パラメータ：
パラメータ (入力引数:文字型)
戻り値 (戻り値:数値型)
エラーメッセージ (戻り値:文字型)

RMViewer C/S版とWeb版のアクセス

RMViewer C/S版とWeb版は、フォームファイル、印刷データファイルに対するアクセス方法が異なります。
C/S版の場合は、ファイルパス指定、Web版の場合は、httpでの指定になります。

  • RMViewer C/S
種類 | 起動例
RMViewer.exe | RMViewer.exe /rfr=sample.rfr /rdata=sample.xml /dsp=y /prn="EPSON LP-9400" /copy=3
RMViewer　HTML

（ActiveX）

<object classid="clsid:D1DDC7EF-52D9-4750-A00F-4022F84B0586" id="RMViewer"
codebase="http://localhost/ReportsMagic/RMViewerCtrl.ocx"
width="100%" height="100%">
<param name="RfrFile" value="C:\\ReportsMagic\\sample.rfr">
<param name="RDataFile" value="C:\\ReportsMagic\\sample.xml">
<param name="ToolBar" value="on">
<param name="PrinterName" value="EPSON LP-9400">　←プリンタ名を指定したい場合
<param name="Copy" value="3"> 　　　　　　　　　　 ←印刷部数を指定したい場合
</object>
  • RMViewer Web
種類 起動例
RMViewer.exe RMViewer.exe /rfr=http://localhost/ReportsMagic/sample.rfr
/rdata=http://localhost/ReportsMagic/sample.xml /dsp=y /prn="EPSON LP-9400" /copy=3
RMViewer　HTML

（ActiveX）

<object classid="clsid:D1DDC7EF-52D9-4750-A00F-4022F84B0586" id="RMViewer"
codebase="http://localhost/ReportsMagic/RMViewerCtrl.ocx#version=2,1,20,3"
width="100%" height="100%">
<param name="RfrFile" value="http://localhost/ReportsMagic/sample.rfr">
<param name="RDataFile" value="http://localhost/ReportsMagic/sample.xml">
<param name="ToolBar" value="on">
<param name="PrinterName" value="EPSON LP-9400">　←プリンタ名を指定したい場合
<param name="Copy" value="3"> 　　　　　　　　　　 ←印刷部数を指定したい場合
</object>

ショートカットキー一覧

RMDesigner

分類 | 動作 | ショートカットキー
ファイル | 新規作成 | Ctrl + N
 | 開く | Ctrl + O
 | 閉じる | Ctrl + W
 | 上書き保存 | Ctrl + S
 | 名前を付けて保存 | Ctrl + Shift + S
 | ﾌﾟﾘﾝﾀの設定 | Ctrl + Shift + P
 | 印刷 | Ctrl + P
 | ｱﾌﾟﾘｹｰｼｮﾝの終了 | Ctrl + Q
編集 | 元に戻す | Ctrl + Z
 | 切り取り | Ctrl + X
 | ｺﾋﾟｰ | Ctrl + C
 | 貼り付け | Ctrl + V
 | 消去 | Del
 | すべて選択 | Ctrl + A
 | 文字列検索 | Ctrl + F
 | 文字列置換 | Ctrl + H
表示 | 拡大表示 | Ctrl + + Ctrl + ;
 | 縮小表示 | Ctrl + -
 | 基準倍率表示 | Ctrl + 1
 | 全体表示 | Ctrl + 0
 | 指定ページ | Alt + N
 | 前ページ | Ctrl + ←
 | 次ページ | Ctrl + →
 | 先頭ページ | Ctrl + Shift + PgUp
 | 最終ページ | Ctrl + Shift + PgDn
ｳｨﾝﾄﾞｳ | 並べて表示 | Ctrl + Shift + K
 | 重ねて表示 | Ctrl + Shift + J
テーブル | 項目選択 | Ctrl+E
ﾍﾙﾌﾟ | RMDesignerのヘルプ | F1

RMViewer

分類 | 動作 | ショートカットキー
ファイル | 開く | Ctrl + O
 | 印刷 | Ctrl + P
 | ｱﾌﾟﾘｹｰｼｮﾝの終了 | Ctrl + Q
表示 | 拡大表示 | Ctrl + + Ctrl + ;
 | 縮小表示 | Ctrl + -
 | 基準倍率表示 | Ctrl + 1
 | 全体表示 | Ctrl + 0
 | 幅に合わせる | Ctrl + 2
 | 全画面表示 | Ctrl + 3
 | 指定ページ | Ctrl + N
 | 前ページ | Ctrl + ←
 | 次ページ | Ctrl + →
 | 先頭ページ | Ctrl + Shift + PgUp
 | 最終ページ | Ctrl + Shift + PgDn
ﾍﾙﾌﾟ | RMViewerのヘルプ | F1

RMViewer ActiveX版（RMViewerCtrl.ocx）では、ショートカットキーは対応していません。

「帳票設定」で指定した用紙サイズ、給紙方法や部数の対応

RMDesignerの「帳票設定」で指定した用紙サイズや給紙方法は、RMViewerで以下の様に対応しています。
デバイスモードのコピーは、フォーム上に登録しているプリンタと一致するプリンタがある場合のみ行います。

  • 用紙サイズ：
    フォーム上に登録しているプリンタと一致するプリンタがある場合には、フォームの用紙サイズに設定します。
    一致するプリンタがない場合には、もっとも近い用紙サイズにします。
  • 用紙方向：
    フォーム上に登録しているプリンタと一致するプリンタの有無に関わらずフォーム上の設定を反映します。
  • 給紙方法：
    フォーム上に登録しているプリンタと一致するプリンタがある場合のみ反映します。
    一致するプリンタが無い場合には、デフォルトの給紙方法にしています。
  • 部数
    フォーム上に登録しているプリンタと一致するプリンタの有無に関わらずフォーム上の設定を反映します。
    プリンタ毎に部数の制限があります。この場合は、プリンタの仕様ににより部数が設定されます。

RMViewer ActiveX版（RMViewerCtrl.ocx）の登録について

RMViewer ActiveX版（RMViewerCtrl.ocx）を使用するには、事前に使用するPCのシステムにActiveX登録を行う必要があります。

●RMDesignerの場合
RMDesignerには、RMViewerの体験版が添付されていますが、ライセンス登録プログラム（RMLicense.exe ）を実施してもActiveXは登録されません。
インストールしたフォルダ上のバッチファイルにより、登録、及び解除を行うことが出来ます。

Addregsvr32.bat | RMViewerCtrl.ocxの登録を行います。
DELregsvr32.bat | RMViewerCtrl.ocxの登録を解除します。

●RMViewerの場合 (C/S)

ライセンス登録プログラム（RMLicense.exe ）によりライセンスの登録を行うことにより、ActiveXを登録します。
すでにシステムに登録済みの場合、確認のダイアログが表示されます。

  • RMViewerを、複数PCにインストールしている場合は、登録を実行したPCのRMViewer.exe、RMViewerCtrl.ocx をコピーし、 上記のバッチプログラムを使用することにより登録、または更新することが可能です。　更新の場合は、　DELregsvr32.bat、Addregsvr32.batを実行 します。

●Web環境（ブラウザ）－ActiveXの自動ダウンロード

HTMLファイルに以下の記述を追加すること自動ダウンロードを行うことが可能です。

<html>
<object classid="clsid:D1DDC7EF-52D9-4750-A00F-4022F84B0586" id="RMViewer"
codebase="http://samplehost/RMViewerCtrl.ocx#version=2,1,20,3"
width="100%" height="100%">
<param name="RfrFile" value="http://samplehost/ReportsMagicV2/EmpfamilyXml.rfr">
<param name="RDataFile" value="http://samplehost/ReportsMagicV2/EmpfamilyMagic.xml">
<param name="ToolBar" value="on">
</object>
</html>

●ActiveXのバージョン番号
ユーザー環境にあるバージョンが CODEBASE の指定よりも古い場合は、CODEBASE で指定した場所から、新しいバージョンの ActiveＸ RMViewer を自動的に ダウンロードおよびインストールさせることができます。
旧バージョンから更新したい場合は、Active-Xモジュール(RMViewerCtrl.ocx)のファイルバージョン(エクスプローラからActive-Xモジュールのプロパティをオープンし、「バージョン情報」タブの「ファイルバージョン」を参照）を指定して下さい。

（例）version=2,0,0,1→version=2,1,20,3

文字列の出力可能範囲について

V1.0Bより文字列の出力可能範囲が厳密に制御されるようになりました。
文字列枠は、内部余白により制御されており、出力する文字列が文字列枠の範囲を超えた文字は、出力されません。

dbFORM形式は、項目の「テキストの折り返し」により出力方式が異なります。
「テキストの折り返し」がチェックされている場合は、ReportsMagicの文書枠のサイズに沿ってて出力します。
「テキストの折り返し」がチェックされていない場合は、ReportsMagicの文書枠のサイズを無視して出力します。

dbFORMの文章データには枠サイズがありますが、文字の場合は枠サイズが存在しません。従って、dbFORMのフォームを読み込んだ場合 、文字は「テキストの折り返し」がチェックなし、文章は、「テキストの折り返し」がチェックありで設定されます。

XML形式で文字列の前に半角スペースは有効にならない

XML形式で文字列で文字列の前に半角スペースを入れると無視される場合があります。
これは、XMLの仕様で前後の半角スペースは、取り除かれる為です。
（例）　<value>△△ＡＢＣＤＥＦ△△</value>　→　ＡＢＣＤＥＦ　　△は、半角スペース

これを回避するには、XMLに以下を追加します。

<ReportsMagic version="1.0" xml:space="preserve">

後ろの半角スペースを有効にしたい場合は、書式を未設定（空白）にします。（V1.0X互換）

「セキュリティ保護の為コンピュータにアクセスできるアクティブコンテンツは表示されないよう、Ｉnternet Explorerで制限されています。オプションを表示するには、ここをクリックしてください...」

ブラウザ上でRMViewerを使用した場合、表示される場合があります。

これはWindows XPのサービスパック2（SP2）のセキュリティ強化に伴って表示されるようになったメッセージでWebページからユーザのコンピュータ上のスクリプトやActiveXコントロールが実行されようとしたときに表示されます。

情報バーをクリックして、ブロックされているコンテンツを許可することは可能ですが、表示するたびに入力が必要になります。以下の操作をすることで、確認画面が表示されなくなります。

▼操作手順
メニュー［ツール］－［インターネットオプション］をクリック
  ↓
［インターネットオプション］ダイアログ－［詳細設定］タブをクリック
  ↓
［設定］－［セキュリティ］欄の、
［マイコンピュータのファイルでのアクティブコンテンツの実行を許可する］チェックをOnにする
  ↓
［インターネットオプション］ダイアログ－［OK］ボタンをクリック

データ連携－データ形式の違い

 | dbFORM | CSV | ヘッダー付き CSV | XML
TAG名ルール | %%数字２階層まで | %%数字 | 任意 | 任意
テーブル | なし テーブル構造の認識は無い | １個 | １個 | 複数可能※２
明示的改ページ | データ内で指定 （ＦＦ） | キー指定 | キー指定 | データ内で指定
暗黙的改ページ | × | ○ キー指定が無い場合は、１レコード毎に改ページ | ○ キー指定が無い場合は、１レコード毎に改ページ | ○
マルチフォーム ※1 | × | △ 暗黙的改ページの場合のみ可能 | △ 暗黙的改ページの場合のみ可能 | ○ データ内で指定 （XML フォーム番号）
マージテンプレート作成支援 | × | × | × | ○
備考 | dbFORMの互換機能を重視した形式です。 今後の拡張予定はありません。ヘッダー付きCSV、XML形式への移行をお奨めいたします。 | データ格納率が高いため、大量印刷の場合に有利です。 | データ格納率が高いため、大量印刷の場合に有利です。 CSV形式に比べて、TAG名を自由に管理できるため、メンテナンス性は向上します。 | マルチフォームをサポートした最も高度なフォーム形式です。 ReportsMagicのデフォルトのフォーム形式です。 CSV形式に比べるとデータ量が大きくなる傾向があります。
  • ※１：ひとつの帳票データで複数のフォームを使用する形態。例えば、１ページ目は納品書、２ページ目は請求書、３ページ目は納品受領書のような形態。
  • ※２：複数テーブル
    ・テーブルのネストは、サポートされません。
    ・暗黙の改ページは、サポートされません。　明示的改ページを使用します。
    ・ブレイク処理は、サポートされません。

ReportsMagicファイル形式一覧

名称 | 拡張子 | 説明
フォームファイル | rfr | RMDesignerによって、設計されたフォームファイル。
圧縮・暗号化
フォームファイル 		rfc

フォームファイル(rfr)が圧縮・暗号化されたファイル。
RMViewerのフォームファイルパラメータに指定可能です。
RMDesigner、又はRMCompSec.RMCS_EncodeX(xpaのユーザプロシージャ)によって作成します。
RMDesignerで編集するこはできません。

印刷データ XML xml XMLデータ形式のフォームファイル（rfr)が読み込み可能な印刷データファイル。
xmlに準拠、エレメント、属性は決められたフォーマットを指定する必要があります。

圧縮・暗号化
印刷データ XML 		xmc

XMLデータファイルが圧縮・暗号化されたファイル。
RMViewerのデータファイルパラメータに指定可能です。
RMCompSec.RMCS_EncodeX(xpaのユーザプロシージャ)によって作成します。
RMDesignerで読込ことはできません。

印刷データ CSV | csv | CSV、又はヘッダ付きCSVデータ形式のフォームファイル（rff)が読み込み可能な印刷データファイル。
圧縮・暗号化
印刷データ CSV 		csc CSVデータファイルが圧縮・暗号化されたファイル。
RMViewerのデータファイルパラメータに指定可能です。
RMCompSec.RMCS_EncodeX(xpaのユーザプロシージャ)によって作成します。
RMDesignerで読込ことはできません。
フラットファイル
（圧縮・暗号化） 		rff フォームファイルと印刷データファイルが一つに構成されたファイル。
V1.3aで言語変換ファイル、V1.4でフォント組込ファイルを同時に構成することが可能になりました。
RMCompSec.RMCS_EncodeX(xpaのユーザプロシージャ)によって作成します。
RMDesignerによっても作成することが可能です。
RMDesignerで読込ことはできません。
拡張フラットファイル
（圧縮・暗号化） 		rff 仮想プリンタドライバ（RM Printer） から出力、又はMagic xpa(3.0以降)のReportsMagic出力からされるフラットファイル。
RMCompSec.RMCS_EFlatSet(xpaのユーザプロシージャ)により、 フォント組込ファイル、起動オプションが設定可能です。
RMDesignerで読込ことはできません。
フォント組込ファイル rfn フラットファイルに組込み可能なフォントファイル。
RMViewerのフォント組込みファイルパラメータでも指定可能です。
RMDesignerによって作成します。
言語変換ファイル mls 言語変換ファイル。
RMViewerの言語変換ファイルパラメータに指定可能です。
V1.3aからフラットファイルに組込みことが可能です。
RMDesignerによって作成します。
dbFORMファイル frm dbFORM（dbSPEC）で作成されたフォームファイル。
RMDesignerに於いてdbFORMのフォームを取り込み事が可能です。

RMCompSec.DLLのエラーコード一覧

エラー番号 | ステータスメッセージ
0 | 正常に終了しました。
-1 | 初期処理に失敗しました。
-2 | 終了処理に失敗しました。
-11 | 引数に誤りがあります。
-12 | ファイルオープンに失敗しました。
-13 | ファイル入出力に失敗しました。
-14 | 圧縮処理に失敗しました。
-15 | 暗号化処理に失敗しました。
-16 | フォームファイルからパスワード抽出に失敗しました。
-17 | バックグランドでは動作しません。
-18 | 圧縮・暗号化処理が実行できませんでした。 （初期処理をしていないか、モジュールが破損していて圧縮・暗号化処理が実行できない場合）
-19 | メモリ不足です。
-20 | モジュールロードに失敗しました。
-21 | 拡張フラットファイルのファイル形式が不正です。
-22 | 拡張フラットファイルとのパスワードが一致しません。
-23 | 拡張フラットファイルのパスワードが指定されていません。
-24 | 出力先フォルダが存在しません。
-25 | 出力先フォルダの作成に失敗しました。
-26 | インデックス先フォルダが存在しません。
-27 | GDI+でエラーが発生しました。
-28 | JPEGファイルの作成に失敗しました。
-29 | 不正なフラットファイルです。
-30 | フォルダの削除に失敗しました。

RMViewer 起動用DLL-RMViewer.DLLのエラーコード一覧

エラー番号 | ステータスメッセージ
0 | 正常に終了しました。
-1 | RMViewerが実行できませんでした。
-2 | ステータスファイルが作成できません。
-3 | RMViewerは実行中です。
-4 | パラメータが不正です。
-100 | OLE の初期化に失敗しました。 OLE ﾗｲﾌﾞﾗﾘのﾊﾞｰｼﾞｮﾝが正しいことを確認してください。
-170 | データ形式が違います。
-202 | DIB が大きすぎます。
-203 | DIB を読み込めません。
-247 | [ファイル名]を読み込むことができません。
-249 | 文書が使用中です。
-250 | ファイルのオープンに失敗しました。
-252 | ファイルの読み込みに失敗しました。
-255 | メモリが不足しています。
-257 | パスワードが一致しません。
-266 | CoInitialize 失敗!
-284 | データ形式が違います。
-287 | 一致するタグがありません。
-295 | ヘルプファイルが見つかりません。
-301 | 指定したプリンタが登録されていません。
-302 | 指定したフォームファイルが存在しません。
-303 | 指定したデータファイルが存在しません。
-305 | ライセンス情報が不正です。
-306 | 使用期限を越えました。
-307 | 現在のライセンスでは、認可されていないアクセス方式です。
-308 | サポートされていないバージョンのフォームです。#[フォームバージョン]
-309 | データファイルが使用中でオープンできません。
-321 | 印刷ジョブを開始できませんでした。
-322 | XXXXX:パラメータが不正です。
-323 | FLATファイルではありません。
-324 | FLATファイルの保存に失敗しました。
-325 | FLATファイルの保存が許可されていません。
-326 | メモリ不足です。(Flatファイル解凍時）
-327 | 指定した用紙サイズ名は無効です。
-328 | 指定した用紙方向名は無効です。
-329 | 指定した給紙方法名は無効です。
-330 | ユーザ定義サイズは無効です。
-331 | リソース不足です。
-332 | 指定したオフセット値は無効です。
-333 | 読み込みファイルの展開に失敗しました。
-334 | 拡張フラットファイルのページデータが存在しません。
-336 | 復元に失敗
-337 | ファイル読み込みに失敗
-338 | サポートされていないバージョン
-339 | 出力ファイルオープンに失敗
-340 | 解凍に失敗
-341 | 体験版で作成されたフォームです。
-342 | 製品版で作成されたフォームです。
-343 | フォームバージョンをRMViewerバージョンにあわせて移行してください。
-344 | 連結FLATファイルに拡張FLATファイルが含まれています。
-345 | 登録しているライセンスではダイレクトフラット以外はオープンできません。

CSV（Comma-Separated Values）

CSV（Comma-Separated Values）は、いくつかのフィールド（項目）をコンマ「,」で区切ったテキストデータおよびテキストファイルです。

（例）
"MSJ","11","山田太郎","山田花子","35","妻" データイメージ（　MSJ 11 山田太郎 山田花子 35 妻）

フィールドは、ダブルクォート「"」 で囲んでも囲まなくても良いです。
（例）
MSJ,11,山田太郎,山田一郎,8,長男 上の例と同じ

フィールドがコンマ、ダブルクォート、改行を含む場合は、かならずダブルクォートで囲みます。　また、フィールドに含まれるダブルクォートは2つ並べてエスケープします。
（例）
"MSJ","11,111","""山田太郎""","""山田花子""",35,"妻" データイメージ（　MSJ 11,111 "山田太郎" "山田花子" 35 妻）

バーコード

郵便カスタマバーコード

ReportsMagicには、郵便カスタマバーコードの「郵便番号」、「住所表示番号」のみを渡します。（最大20桁）

（例）10000131-3-2-503

カスタマバーコードに必要な文字情報の抜き出しから生成までの処理概要
住所を町域名までの住所Aと町域名以降の住所Bに分割します。

東京都千代田区霞が関1丁目3番2号　郵便プラザ503室
住所

東京都千代田区霞が関
住所A
町域名までの住所(郵便番号)

1丁目3番2号　郵便プラザ503室
住所B
町域名以降の住所(住所表示番号)

町域までの住所に郵便番号を設定します。

町域名以降の住所(住所表示番号)からバーコードとして必要な文字情報(住所表示番号)を抜き出します。

100-0013
(郵便番号)

1-3-2-503
(住所表示番号)

前記の郵便番号と住所表示番号を連結してカスタマバーコードの情報とします。

[カスタマバーコードの情報]

1000013
郵便番号
(注1)

1-3-2-503
住所表示番号

(注1)バーコードの情報を生成するときは、郵便番号の3～4けた目間のハイフンを省きます。

前記のカスタマバーコードの情報にチェックデジット、スタートコード、ストップコードを付加してカスタマバーコードを生成します。

(注2)「CC4」は、住所表示番号部分が13けたに満たない場合に充足する制御コードです。　13桁に不足した場合は、ReportsMagicが自動的に付加します 。
(注3)「チェックデジット9」は、ReportsMagicが自動的に付加します。

  • 詳細は、日本郵政の郵便番号・バーコードマニュアルを参照してください。
    http://www.post.japanpost.jp/zipcode/zipmanual/index.htm
  • バーコードの端から端までが64mm～88mmの範囲になるようにします。

Magic xpa Web／RIAにおけるRMViewerの実装、配布

Magic xpa Web／RIA環境でのRMViewerの実装、配布の概要です。

Magic側の実装 | RMViewer モジュール | RMViewer配布方法 | RMViewer製品 | 備考
【Web】Webマージ（ブラウザ） | RMViewer Cab（ActiveX） | ブラウザ機能※1 | RMViewer Web／RMViewer RIA | ・印刷データの読み込み（ダウンロード）は、ブラウザが実行
【RIA】ブラウザコントロール | RMViewer Cab（ActiveX） | ブラウザ機能※1 | RMViewer Web／RMViewer RIA | ・印刷データの読み込み（ダウンロード）は、ブラウザが実行
【RIA】.NETインテグレーション | RMViewerCtrl.ocx（ActiveX） | ClickOnce | RMViewer Web／RMViewer RIA | ・Magic xpa RIAモジュールにRMViewer（RMViewerCtrl.ocx）を含めて配布 ・印刷データの読み込み（ダウンロード）は、Magic xpa .NETインテグレーションで実行
【RIA】OSコマンド | RMViewer.exe | 手作業ダウンロード | RMViewer RIA | ・Webサーバ経由でRMViewer C/S EXE版をダウンロードしインストール。 ・ライセンス以外は、RMViewer C/S のインストールとほぼ同様。 ・印刷データの読み込み（ダウンロード）は、直接Webサーバへアクセスでも、ローカルディスクでも可能。（オフライン可能） ・RMExeViewer.exeでRMViewer C/S を起動

  • ※1：参考「RMViewer ActiveX版（RMViewerCtrl.ocx）の登録について」

  • 印刷データは、ReprotsMagicフォーム＋印刷データ、フラットファイル、拡張フラットファイルを意味します。

RIA開発、テスト環境でRMViewerを使用する場合の注意点

RIA開発において、開発、及びテスト環境でRMViewerを使用する場合には、以下の様な考量点があります。

  • 製品版（RMViewer RIA／RMViewer Web）を使用する場合は、ライセンス上の注意が必要です。（運用環境と異なるWebサーバ環境を使用する場合は、別途ライセンスが必要とないます。）
  • RMViewer配布のテストを実施したい場合は、RMDesignerに添付された、RMViewer （体験版）を使用することで確認する事が出来ます。
  • RMViewer RIAで提供されている「RMViewer exe版」の体験版はありません。　ダウンロード、及びインストールを確認することは出来ませんが、実行の確認はRMViewer C/Sをクライアントへ事前にインストールすることにより、動作確認をすることが可能です。　ライセンス登録無しの体験版の状態でも確認可能です。

製品毎のRMViewerの添付モジュール概要：

モジュール | RMDesigner | RMViewer C/S | RMViewer RIA | RMViewer Web
RMViewer.exe | 体験版 | 初期状態状態は体験版 ライセンス登録実施 | ライセンス組込済 | ライセンス組込済
RMViewerCtrl.ocx | 体験版 デジタル署名済 | 初期状態状態は体験版 ライセンス登録実施 デジタル署名無し | ライセンス組込済 デジタル署名済 | ライセンス組込済 デジタル署名済
RMViewerActiveX.cab | 体験版 デジタル署名済 | ☓ | ライセンス組込済 デジタル署名済 | ライセンス組込済 デジタル署名済
RMViewerRIAV20.exe （RMViewer exe版） | ☓ | ☓ | ライセンス組込済 デジタル署名済 | ☓

  • RMDesigner、RMViewer RIA、RMViewer Web上のライセンス登録プログラムでRMViewer C/Sのライセンス登録を行うと、ライセンス情報が書き変わるだけでなく、デジタル認証も削除されます。


各種リンク情報

以下のリンク先にも参照してください。

MSJ のホームページ(TOPページ)

技術情報サイト DEVNET

XML対応帳票ソリューション「ReportsMagic」

Magic xpa Application Platform

Magicアップデートのダウンロード(ReportsMagic)

Magic製品サポート・ライフサイクル(ReportsMagic)

テクニカルサポート（サポート契約のご案内）

プロフェッショナルサービス

トレーニングコース

Magicスキルアップセンター

Magic開発者のためのプログラム最適化ツール「Magic Optimizer」

パッケージソフト紹介サイト


ベータ版評価レポートのお願い

ベータ機能－評価レポートのお願い

提供するプログラム機能の一部が、ベータ機能として提供される場合があります。これらの機能はマジックソフトウェアジャパンのサポートセンターでのサポート対象外です。
又、ご意見、ご質問、気が付いた点などは、下記の「ベータ評価レポート」に記入して、メールで japan_mgxpa_beta@magicsoftware.com までお送りください。
お送りいただいたレポートは、製品改善のための参考にさせていただきますが、お問い合わせの内容に対し個別にはお答えできない場合もありますので、予めご了承願います。

ReportsMagic V2.1 ベータ機能評価レポート

記入日： ２０１６年　　 月　 日
会社名：
担当者：
E-mail：
ＴＥＬ：
ＦＡＸ：
サポート契約： （ ）Windows　（ ）フルセット　 （ ）なし 該当する（ ）に＊を挿入してください。

１．動作環境
ＰＣ機種：
ＣＰＵ：
ＲＡＭ：
ＯＳ： （ ）WindowsVista ／（ ）Windows7 ／（ ）Windows8 ／（ ）Windows10
（ ）Windows2008／（ ）Windows2008(x64)／（ ）Windows2012
ＩＭＥ：
ビデオカード：
使用ブラウザ：

２．不具合の場合

不具合を確認した場合は、こちらに記入してください。 該当する（ ）に＊を挿入してください。

Ａ （ ） 一部支障あり
Ｂ （ ） 正常に動作しない
Ｃ （ ） インストール・起動不可

２．１．再現性

（ ）再現性あり、 （ ）時々再現する、 （ ）再現性なし

２．２．不具合の現象 （できるだけ詳細にお書きください。現象確認を迅速に行なう
ために、極力画面のハードコピー、フォームデータ、サンプルプログラム等の提供をお願い
いた します。　異常終了するような場合は、ワトソン博士のログ の提供もお願いいたします。）

３．要望事項
機能追加、改善要望等がありましたら、こちらに記入してください。
（できるだけ詳細にお書きください。）

４．その他ご意見

以上


ReportsMagic製品構成

製品構成
RMDesignerのライセンスについて
RMViewer C/Sのライセンスについて
RMViewer Web版のライセンスについて
RMViewer RIA(RichClient)版のライセンスについて
 WTS(Windows Terminal Server)、Citrix Presentation Server で使用する場合の注意点

ReportsMagic は、大きく分けて、印刷フォームを作成するRMDesignerと印刷結果を表示（ビューワ）、印刷するRMViewerの２種類の製品から構成されます。

製品構成

製品名 | ライセンス | 備考
RMDesigner | １ユーザ | インストールベース RMViewer体験版付き
RMDesigner エンタープライズパック | ５ユーザ | インストールベース 開発用RMViewer C/S ５ユーザ付き
RMViewer C/S版 | １～ | 同時アクセスユーザ数 通常、Magic Clientと同一ユーザ数を購入 アクセス方式（ファイルアクセス）
RMViewer Web版 | サーバ | サーバ単位※1 アクセス方式（Hｔｔｐアクセス）
RMViewer RIA(RichClient)版 | ユーザ | Magicリッチクライアント（Magic xpa RIA Server/uniPaaS RichClient Server）用※2 Magicリッチクライアントと同一ユーザ数を購入 アクセス方式（ファイルアクセス、Hｔｔｐアクセスの両方） クライアント用のRMViewer exeインストーラ提供※3
 | サーバ | Magicリッチクライアント（Magic xpa RIA Server/uniPaaS RichClient Server）用※2 サーバ単位※1 アクセス方式（ファイルアクセス、Hｔｔｐアクセスの両方） クライアント用のRMViewer exeインストーラ提供※3
  • ※1：CPU数や使用ユーザー数に依存しません。 1サーバへのインストールです。（RMViewer配布目的）
    ただし、ReportsMagicの印刷データ生成、圧縮／解凍化の為にMagicサーバ（Magic xpa Enterprise Server/uniPaaS Enterprise Server/Magic xpa RIA Server/uniPaaS RichClient Server）にインストールする場合は、別サーバに１台のみインストールすることが可能です。 複数のWebサーバ、複数のMagicサーバを使用する場合は、累計したサーバライセンスが必要です。
  • ※2：Magic Client (Magic xpa Enterprise Client/uniPaaS Client)と組合わせて使用することは出来ません。
  • ※3：WebサーバからダウンロードしてクライアントPCにRMViewer exe版をインストールするものです。 単独で動作しますが、Magicリッチクライアントのシステム範囲のみで使用可能です。

各製品の機能比較

 |  | RMDesigner | RMViewer C/S | RMViewer Web | RMViewer RIA(RichClient)
 |  |  |  |  | ユーザ | サーバ
印刷フォーム作成機能 |  | ○ |  |  |  |
RMViewer 実装方式 | EXE |  | ○ | △※1 | ○ | ○
 | ActiveX |  | ○ | ○ | ○ | ○
RMViewer アクセス方式 | ファイル |  | ○ |  | ○ | ○
 | http |  |  | ○ | ○ | ○
圧縮／暗号化DLL |  | シングルスレッド | シングルスレッド | マルチスレッド | マルチスレッド | マルチスレッド
仮想プリンタードライバ※3 |  | ○ | × | ○ | ○ | ○
RMViewer exe ダウンロード形式インストーラ |  |  |  |  | ○※2 | ○※2
ライセンス |  | 特定のPC1台のみ | 同時ユーザ数 | サーバ | 同時ユーザ数 | サーバ

※1：メンテナンス用としてWebサーバ上でのみ使用可能なExe版が提供されています。
※2：Magic Client と組合せて使用することは出来ません。
※3：運用環境ではサーバ製品（RMViewer Web、RMViewer RIA）のみが使用できます。

RMDesignerのライセンスについて

RMDesignerのライセンスは、以下のようになります。

  • RMDesignerのライセンスは、特定のPC1台にのみインストール可能で、かつ、同時に1人のユーザのみが利用可能です。
  • エンタープライズパックは、5ユーザのライセンスがパックされた製品です。　特定のPCの 5台にインストール可能です。
  • RMViewer体験版が添付されています。　エンタープライズパックの場合は、開発目的で使用できるRMViewer C/S 5ユーザが提供されています。
  • インストール直後は、制限つきの体験版として動作します。ユーザ登録センターへ申請手続きを行い、正式ライセンスの Activation Keyを入手し、ライセンスをインストールすることによって、制限なしの正式版として動作します。

RMViewer C/Sのライセンスについて

RMViewer C/S のライセンスは、以下のようになります。

  • RMViewer C/Sのライセンスは、同時アクセスユーザ数となり、Magic Clientと同一ユーザ数を購入します。　Magic Clientによって、同時アクセスの制御を行います。
  • RMViewer exe版、ActiveX版を使用可能です。
  • アクセス方法は、ファイルアクセスのみサポートされます。
  • インストール直後は、制限つきの体験版として動作します。ユーザ登録センターへ申請手続きを行い、正式ライセンスの Activation Keyを入手し、ライセンスをインストールすることによって、制限なしの正式版として動作します。
  • 複数ユーザ版のインストールは、ファイルサーバ上にRMViewerをインストールし、各クライアントで共有することが可能です。

RMViewer Web版のライセンスについて

RMViewer Web版 のライセンスは、以下のようになります。

  • RMViewer Web版のライセンスは、サーバライセンスです。 CPU数や使用ユーザ数に依存しません。 1サーバへのインストールです。（RMViewer配布目的）
    ただし、ReportsMagicの圧縮／暗号化の為にMagicサーバ（Magic xpa Enterprise Server/uniPaaS Enterprise Server/Magic xpa RIA Server/uniPaaS RichClient Server）にインストールする場合は、別サーバに１台のみインストールすることが可能です。 複数のWebサーバ、複数のMagicサーバを使用する場合は、累計したサーバライセンスが必要です。

※上記の例は、RMViewer ActiveX配布用に1台のWeb サーバ、圧縮処理の為に2台のMagic xpa Enterprise Serverを使用しています。　RMViewer Web版は、2サーバ分のライセンスが必要です。

  • RMViewer ActiveX版を使用可能です。　ただし、メンテナンス用としてWebサーバ上でのみ使用可能なRMViewer Exe版が提供されています。
  • アクセス方法は、Httpアクセスのみサポートされます。

RMViewer RIA(RichClient) 版のライセンスについて

RMViewer RichClient 版 のライセンスは、以下のようになります。

  • Magicリッチクライアント（Magic xpa RIA Server/uniPaaS RichClient Server）用のRMViewerです。　Magic Client と組合せて使用することは出来ません。
  • RMViewer RIA(RichClient)版のライセンスは、同時アクセスユーザ数と、サーバライセンスの二種類があります。
    一般的にユーザ数が少ない構成の場合は、同時アクセスユーザ数が、ユーザ数が多い場合は、サーバライセンスの方が安価な構成になります。
  • 同時アクセスユーザ数の場合は、Magicリッチクライアントと同じユーザ数を購入します。
  • サーバライセンスの場合、CPU数や使用ユーザ数に依存しません。 1サーバへのインストールです。
    ただし、ReportsMagicの圧縮／暗号化の為にMagicサーバ（Magic xpa Enterprise Server/uniPaaS Enterprise Server/Magic xpa RIA Server/uniPaaS RichClient Server）にインストールする場合は、別サーバに１台のみインストールすることが可能です。 複数のWebサーバ、複数のMagicサーバを使用する場合は、累計したサーバライセンスが必要です。

※上記の例は、RMViewer ActiveX/EXE配布用配布用に1台のWebサーバ、圧縮／暗号化処理の為に2台のMagic xpa Enterprise Serverを使用しています。　サーバライセンスの場合は、RMViewer RIA(RichClient)版は、２サーバ分のライセンスが必要です。

  • RMViewer ｅｘｅ版、ActiveX版を使用可能です。　exe版は、クライアントにダウンロードしてインストールするインストーラが提供されています。
  • アクセス方法は、ファイルアクセス、Httpアクセスの両方をサポートします。
  • クライアント上でRMViewer ｅｘｅ版を起動することが可能です。

WTS(Windows Terminal Server)、Citrix Presentation Server で使用する場合の注意点

  • 接続して使用する可能なクライアント台数分のライセンス（RMDesigner、RMViewer）の購入が必要になります。
  • Magicサポートセンターでは、WTS、Citrix Presentation Server（MetaFrame）に関する問い合わせは、サポート対象外となります。
  • 詳細は、最寄の弊社営業所へお問い合わせください。


動作環境

ReportsMagic 動作環境

●ReportsMagic Ver2.0

製品 | 対応環境
RMDesigner | Windows Vista／7／8／10 Windows 2008／2012
RMViewer | Windows Vista／7／8／10 Windows 2008／2012 ブラウザ Internet Explorer 7以上
Magic 対応 | ActiveX組込 V10／Magic uniPaaS V1／Magic uniPaaS V1Plus／Magic xpa（※1） Exe起動 V10／Magic uniPaaS V1／Magic uniPaaS V1Plus／Magic xpa .NETコントロール Magic xpa
仮想プリンタドライバ | 開発環境 Windows Vista／7／8／10 運用環境（サーバ） Windows 2008／2012 運用環境（クライアント）（※2） Windows Vista／7／8／10

  • プロセッサは、Intel x86アーキテクチャ、およびその互換プロセッサのみサポートしています。
  • x64 (64bit) Editionについては、Windows Server 2008／2012、Windows7／8／10についてのみ対応しています。 WOW64上で正常に動作することを確認しております。 仮想プリンタドライバは、Nativeの64bit版が提供されていますが、Windows Server 2008／2012、Windows7／8／10 についてのみ対応しています。
  • （※1） ブラウザコントロールのみサポート。 Magicオンラインタスクへの組み込みはサポートされません。 Magicオンラインタスクへ組み込みたい場合は、 .NETコントロールを使用してください。
  • （※2）ネットワークプリンタを使用してサーバ側にある仮想プリンタドライバを使用します。


ReportsMagic FAQ

製品体系・製品概要について

  • ReportsMagicの製品概要は？

  • Magicで開発された印刷プログラムの帳票フォーム（テキスト形式、GUI形式）をReportsMagicに自動移行するのですか？

  • 印刷データのフォームは、どのような形式があるのですか？

  • ReportsMagicがDBを直接アクセスすることはできないのですか？

  • インターネット環境で使用可能ですか？

  • フラットファイルとは何ですか？

動作環境

  • ReportsMagicの動作環境は？

  • Windows 8／Windows 2012対応は？

  • Windows x64には対応していますか？

  • 仮想環境上での使用は、サポートされていますか？　その場合ライセンスはどうなりますか？

ReportsMagicライセンス関連

  • ReportsMagicのライセンス概要はどのようになっていますか？

  • RMDesigner：一人の開発者が、複数のPCで開発を行っています。　RMDesigner １ユーザを複数のPCにインストールすることはできますか？

  • RMViewer C/S版 ：Magic Client とRMViewer C/Sを組合せて使用する場合、何ユーザを購入すればよいですか？

  • RMViewer Web版 ：RMViewer exe版は、どのように使用するのでしょうか？

  • RMViewer RichClient版：RMViewer RichClient版を C/Sシステムで使用することは可能ですか？

  • Magicリッチクライアント（RIA）環境で、RMViewer Web版を使用することは可能でしょうか？

  • Magic eDeveloper以外で開発されたシステムでReportsMagicを使用することは可能ですか？　又、その場合のライセンスはどのようになりますか？

  • ReportsMagic－サイト単位で使用するライセンス形態、またはパッケージで使用するライセンス形態等の、ライセンス形態はありますか？

  • コールド・スタンバイでの使用する場合は、ライセンスはどうなりますか？

インストール関連

  • クライアント側には何をインストールしますか？

  • RMViewer C/Sの複数ユーザ版は、どのようにしてインストールするのですか？

  • RMViewer Web版、RMViewer RichClient版は、どのようにインストールするのですか？

  • RMViewer RichClient版で提供されている、RMViewer exe版はどのようにインストールするのですか？

ReportsMagic の製品仕様

  • Unicodeは、サポートされていますか？

  • 外字は使用できますか？

  • どのようなプリンタ（例えば、ドットインパクトプリンタ）でも印刷可能ですか？

  • RMViewerでプレビューしないで、バックグランド印刷することは可能でしょうか？

  • RMViewer RichClient版で、 RMViewer ActiveX版とRMViewer exe版の違いは、どのような点が異なるのでしょうか？

  • ReportsMagicとPDFの違いは、どのような点ですか？

  • バーコードは、どのような種類をサポートしていますか？

  • 圧縮・暗号化は、印刷フォーム、印刷データ単位で可能ですか？

仮想プリンタードライバ

  • 仮想プリンタードライバとは、なんですか？

  • Microsoft Officeなど、Magic以外のアプリケーションで仮想プリンタードライバを使用することは可能ですか？

  • Magicのテキスト印刷では、仮想プリンタードライバを使用することが可能ですか？

  • 仮想プリンタードライバは、運用環境ではサーバ製品（RMViewer Web版、RMViewer RichClient版）のみとなっていますが、C/S環境では使用することは出来ないのでしょうか？

サポート・サービス

  • インストール、導入教育、帳票設計支援等のサービスはありますか？

  • テクニカルサポートはどうなりますか？

製品体系・製品概要について

Ｑ | ReportsMagicの製品概要は？
Ａ | 「ReportsMagicの製品構成」をご確認ください。
 | Totop
Ｑ | Magicで開発された印刷プログラムの帳票フォーム（テキスト形式、GUI形式）をReportsMagicに自動移行するのですか？
Ａ | いいえ。 お客様がReportsMagicの仕様に合わせて新規にプログラムを開発する必要があります。 RMDesigner で印刷フォームを作成します。 Magicで印刷用の印刷データを生成（XML、CSV出力）し、RMViewerで印刷フォーム、印刷データを読込んで印刷します。
 | Totop
Ｑ | 印刷データのフォームは、どのような形式があるのですか？
Ａ | XML形式、CSV形式、ヘッダー付きCSV形式、dbFORM形式があります。 XML形式は、推奨の形式です。 高度な印刷フォームに対応可能です。 CSV形式、ヘッダー付きCSV形式は、単純な帳票に適しており、データ格納率は高いのが特徴です。 dbFORM形式は、DOSの帳票ツールであるdbFORM移行用に準備されたものです。
 | Totop
Ｑ | ReportsMagicがDBを直接アクセスすることはできないのですか？
Ａ | 出来ません。
 | Totop
Ｑ | インターネット環境で使用可能ですか？
Ａ | はい。 ReportsMagicで使用する印刷フォーム、印刷データと同一ものを、C/S環境、Web環境で使用することが可能です。
 | Totop
Ｑ | フラットファイルとは何ですか？
Ａ | ReportsMagicの印刷フォームと印刷データを1つファイルに統合したものです。 PDFのように一つのファイルで構成されます。 従って、RMViewer exe版がインストールされている環境では、ダブルクリックで開くことが可能です。 Ver1.4からは、仮想プリンタードライバが提供されMagic GUI印刷でもフラットファイルを作成することが可能になりました。 仮想プリンタードライバで作成されたフラットファイルを拡張フラットファイルと言います。
 | Totop

動作環境

Ｑ | ReportsMagicの動作環境は？
Ａ | 「ReportsMagicの動作環境」をご確認ください。
 | Totop
Ｑ | Windows 8／Windows 2012対応は？
Ａ | ReportsMagic Ver2.0でWindows 8／Windows 2012に対応しました。 ただし、周辺ソフトウェアに関しては、各ベンダの対応状況をご確認ください。
 | Totop
Ｑ | Windows x64には対応していますか？
Ａ | Windows2008/2012、Windows7/8では、WOW64環境で検証済みです。
 | Totop
Ｑ | 仮想環境上での使用は、サポートされていますか？ その場合ライセンスはどうなりますか？
Ａ | 仮想環境（Hyper-V、VMWare など）上で、ReportsMagicは実環境同様に動作しますが、仮想環境での動作を保証するものではありません。 仮想環境固有の問題についてはサポートできません。 サポートセンターにおいては、Hyper-V、VMWareの仮想化環境を用意しており、仮想化環境上で実行しているReportsMagic製品についての質問も受け付けますが、仮想環境上の固有な問題であると判明した場合には、それ以上の原因・対策の追求、HotFix等のご提供等の対応が出来ない場合があります。 またMagic uniPaaS製品は、他社のDBMS製品を通してデータにアクセスしているので、ご利用になるDBMS製品が仮想環境で動作保証されていることが前提となります。仮想環境における動作保証については、各DBMSベンダー様にご確認ください。 仮想化環境に固有な問題になる可能性があるものとしては、以下のようなものが考えられます。 ・Magic uniPaaSサーバ製品でライセンスサーバも動作させる場合、HOST-IDも仮想化されるため、特別なライセンスを発行する必要がある可能性もあります。ライセンスサーバは仮想環境ではなく、実サーバにインストールすることをお勧めします。 ・仮想化ソフトウェアの高可用性・負荷分散機能等を利用する場合、実ハードウェアでは想定されないような環境的変化がある場合があり、uniPaaSの動作に影響を与える可能性があります。 ・仮想化ソフトウェア上でサーバ製品をフェイルオーバー構成で使用する場合、別途スタンバイライセンスが必要になります。 ライセンスの詳細に関しては、最寄の営業所か、Webからお問合せください。
 | Totop

ReportsMagicライセンス関連

Ｑ | ReportsMagicのライセンス概要はどのようになっていますか？
Ａ | 「ReportsMagicの製品構成」をご確認ください。
 | Totop
Ｑ | RMDesigner：一人の開発者が、複数のPCで開発を行っています。 RMDesigner １ユーザを複数のPCにインストールすることはできますか？
Ａ | 出来ません。 RMDesignerはインストールベースのライセンスです。 １ユーザを複数のPCにインストールすることは出来ません。
 | Totop
Ｑ | RMViewer C/S版 ：Magic Client とRMViewer C/Sを組合せて使用する場合、何ユーザを購入すればよいですか？
Ａ | Magic Clientと同数のユーザ数を購入してください。 Magic Clientは、バージョンによりライセンス管理方法が異なりますので詳細は、各バージョンの製品構成を参照してください。
 | Totop
Ｑ | RMViewer Web版 ：RMViewer exe版は、どのように使用するのでしょうか？
Ａ | メンテナンス用としてWebサーバ上でのみ使用可能です。 クライアント上での使用はできません。 又、印刷フォーム、印刷データへのアクセスはhttpのみ可能です。
 | Totop
Ｑ | RMViewer RichClient版：RMViewer RichClient版を C/Sシステムで使用することは可能ですか？
Ａ | 出来ません。 RMViewer RichClient版は、Magicリッチクライアントでのみ使用できるものです。 C/Sシステム、Magicリッチクライアントの両方を混在して使用する場合は、両方のライセンスが必要です。
 | Totop
Ｑ | Magicリッチクライアント（RIA）環境で、RMViewer Web版を使用することは可能でしょうか？
Ａ | 可能です。 ただし、ブラウザコントロール（ブラウザ機能）のみでしか使用できません。 RMViewer exeを使用したバックグランド印刷、ファイルアクセス、オフラインでの印刷等は対応出来ません。 システム要件に柔軟に対応可能なRMViewer RichClient版を使用されることをお奨めいたします。
 | Totop
Ｑ | Magic uniPaaS以外で開発されたシステムでReportsMagicを使用することは可能ですか？ 又、その場合のライセンスはどのようになりますか？
Ａ | ReportsMagicは、Magic uniPaaS で使用する印刷ソリューションとして設計されています。 技術的には他の言語（VB .NET、Javaなど）でも使用することは可能ですが、正式な動作検証を行っていません。 サポート範囲外となります。 使用される場合は、事前に動作検証を行い、お客様の責任の範囲でご使用ください。 その場合、ライセンスに関しては、ReportsMagicのライセンスを守る必要があります。 RMViewer C/Sの場合は、インストールベースライセンスとなります。 RMViewer RichClient版は、ご使用できません。
 | Totop
Ｑ | ReportsMagic－サイト単位で使用するライセンス形態、またはパッケージで使用するライセンス形態等の、ライセンス形態はありますか？
Ａ | 最寄の営業所にご確認ください。
 | Totop
Ｑ | コールド・スタンバイでの使用する場合は、ライセンスはどうなりますか？
Ａ | MViewerを圧縮／暗号化処理の為にMagicサーバ（uniPaaS Enterprise Server、uniPaaS RichClient Server ）にインストールした場合、可用性向上のためにコールド・スタンバイやホット・スタンバイが必要になる場合があります。 コールド・スタンバイは、ソフトウェア使用許諾書の許諾プログラム等の複製の (1) で記載されている「バックアップを目的とする複製」とみなし、ライセンスの追加購入の必要はありません。
 | Totop

インストール関連

Ｑ | クライアント側には何をインストールしますか？
Ａ | 運用環境により異なります。 C/S環境（RMViewer C/S） ・クライアント側にRMViewer Exe／RMViewer ActiveＸをインストールします。 Web環境、RichClient環境 ・クライアント側にブラウザを使用してRMViewer ActiveＸをアドオンします。 ・RichClient版では、RMViewer exe版をダウンロードしてインストールすることも可能です。
 | Totop
Ｑ | RMViewer C/Sの複数ユーザ版は、どのようにしてインストールするのですか？
Ａ | 複数ユーザ版は、ファイルサーバ（共有フォルダ）にRMViewer をインストールし、各クライアントで「環境設定」を行います。環境設定を行うことにより、共有フォルダへのショートカット作成や、各クライアントPCへのRMViewer－ActiveXの登録を実施します。
 | Totop
Ｑ | RMViewer Web版、RMViewer RichClient版は、どのようにインストールするのですか？
Ａ | Webサーバ（ＩＩＳ）があるWindows Server環境上でインストールを行います。 又、別PC上にあるuniPaaS Enterprise Serverや、uniPaaS RichClient Server で圧縮／暗号化DLLを使用する場合には、同様にインストールします。
 | Totop
Ｑ | RMViewer RichClient版で提供されている、RMViewer exe版はどのようにインストールするのですか？
Ａ | Webサーバからダウンロードして各クライアントにインストールを行います。 RMViewer C/S版とほぼ同一仕様ですが、以下が異なります。 ・ファイルアクセス、HTTPアクセスの両方が可能 ・ライセンス登録を行う必要がない。（ライセンス登録済みのモジュールを提供） ・クライアント上のRMViewer exe版の起動用コマンドの提供
 | Totop

ReportsMagic の製品仕様

Ｑ | Unicodeは、サポートされていますか？
Ａ はい。　Ver1.3よりサポートされました。
フォームデータは、Unicodeで格納されています。（旧バージョンのフォームを移行すると自動的にコンバートします）
印刷データは、SJIS（デフォルト）、UTF-8、UTF-16、UTF-16-ビッグエンディアンに対応しています。
サロゲート・ペア文字（4バイトのUnicode文字）については、対応していません。

Totop
Ｑ | 外字は使用できますか？
Ａ Ver1.3までは、実行するPCに事前に外字を登録しておく必要があります。
Ver1.4からは、フォント、外字をフォントファイルとして指定できるようになりました。　フラットファイルの場合は、一つのフラットファイル内に組込むことが可能です。

Totop
Ｑ | どのようなプリンタ（例えば、ドットインパクトプリンタ）でも印刷可能ですか？
Ａ | Windows対応のプリンタドライバが用意されていれば、印刷可能です。

Totop
Ｑ | RMViewerでプレビューしないで、バックグランド印刷することは可能でしょうか？
Ａ RMViewer exe版では、起動パラメータで指定することが可能です。
RMViewer ActiveX版では、出来ません。
又、出力先のプリンタを指定することも可能です。

Totop
Ｑ | RMViewer RichClient版で、 RMViewer ActiveX版とRMViewer exe版の違いは、どのような点が異なるのでしょうか？
Ａ
 | RMViewer ActiveX版 | RMViewer exe版
Magicのプログラム | ブラウザコントロール（Webブラウザの機能） | OSコマンドを使用 RMViewer起動用のコマンドが提供されています。
インストール | ブラウザのプラグイン | インストーラをダウンロードしてインストールする
バックグランド印刷 | 不可 | 可能
オフライン | 不可 | Flatファイルをクライアント上にダウンロードしていれば、ダブルクリックで開くことが可能

Totop
Ｑ | ReportsMagicとPDFの違いは、どのような点ですか？
Ａ
 | ReportsMagic | PDF
[ライセンス] ビューワ | 有償 | 無償
[ライセンス] Flat/PDFファイル作成 | ビューワに含まれます | 原則有償
Flat/PDFファイル 生成処理のスピード | ◎（速い） | △（やや遅い）
Flat/PDFファイル ファイルサイズ | ◎（小さい） △（拡張Ｆｌａｔファイル） | △（やや大きい）
Flat/PDFファイル フォント組込み（外字） | 〇 | ○
Flat/PDFファイル 動的イメージ組込み | 〇 | ○
表示までの速度 | ◎（速い） | ○（ある程度は速い）
Magicプログラム構造 | 印刷データ（XML／CSV)出力 Magicの印刷プログラム（仮想プリンタードライバ使用） | Magicの印刷プログラム
印刷フォーム作成 | RMDesigner Magicの印刷プログラム（仮想プリンタードライバ使用） | Magicのフォーム ※通常はMagicの帳票フォーム（テキスト形式、GUI形式）を使用しますが、ReportsMagicからPDFを生成することも可能です。

※弊社の比較によるものです。

Totop
Ｑ | バーコードは、どのような種類をサポートしていますか？
Ａ 以下のバーコードに対応しています。

【一次元コード】
JAN13、JAN8、ITF、NW7、CODE39、 CODE128、UPC(E)
郵便カスタマバーコード、GS1-128（EAN128）、標準料金代理収納

【二次元コード】
QRコード

Totop
Ｑ | 圧縮・暗号化は、印刷フォーム、印刷データ単位で可能ですか？
Ａ 印刷フォーム形式別に、印刷フォーム、印刷データ、及びフラットファイルの単位に圧縮・暗号化が可能です。
これにより、印刷フォームは事前にクライアント側に配布しておき圧縮・暗号化した印刷データのみを配布する方法や、フラットファイル化して同時に配布する等、色々なシステム要件に対応可能です。

ReportsMagicファイル拡張子
ファイル | 標準拡張子 | 圧縮+暗号化 拡張子
フォームファイル | RFR | RFC
印刷データ-XML | XML | XMC
印刷データ-CSV | CSV | CSC
フラットファイル 拡張フラットファイル | － | RFF
フォント組込ファイル | RFN | －
言語変換ファイル | MLS | －
dbFORMファイル | FRM | －

Totop

仮想プリンタードライバ

Ｑ | 仮想プリンタードライバとは、なんですか？
Ａ | PDFの仮想プリンタードライバがPDFファイルを生成するように、ReportsMagicのフラットファイルを生成するプリンタードライバです。 これにより、Magic GUI印刷でもフラットファイルを生成することが可能になります。 従来のフラットファイルは、印刷フォームと印刷データを統合して作成していましたが、仮想プリンタードライバの場合はReportsMagicの印刷フォームを必要としません。 仮想プリンタードライバで作成されフラットファイルを拡張フラットファイルと言います。 RMViewerはフラットファイル、拡張フラットファイルとも区別なく使用することが可能です。 Ver1.4からサポートされました。
 | Totop
Ｑ | Microsoft Officeなど、Magic以外のアプリケーションで仮想プリンタードライバを使用することは可能ですか？
Ａ | Magicサポート（有償）で対応します。 インシデントによりテクニカルなご質問に回答します。 詳細は、「サポート契約のご案内」をご確認ください。
 | Totop
Ｑ | Magicのテキスト印刷では、仮想プリンタードライバを使用することが可能ですか？
Ａ | Windows版プリンタドライバを使用している場合は、使用することが可能です。 DOS互換版プリンタドライバを使用している場合は、使用できません。
 | Totop
Ｑ | 仮想プリンタードライバは、運用環境ではサーバ製品（RMViewer Web版、RMViewer RichClient版）のみとなっていますが、C/S環境では使用することは出来ないのでしょうか？
Ａ | 仮想プリンタードライバを使用するWindows Server環境を準備しサーバ上で処理するに３階層システムにします。 C/Sで使用するRMViewerとは別途、RMViewer RichClient版が必要です。 詳細は、最寄の営業所にご確認ください。
 | Totop

サポート・サービス

Ｑ | インストール、導入教育、帳票設計支援等のサービスはありますか？
Ａ | ReportsMagicは、シンプルな設計になっていますので、現在通常のメニューとしては用意しておりません。 お客様のご要望に幅広くご対応できるプロフェッショナルサービスもご用意しておりますので最寄の営業所にご確認ください。
 | Totop
Ｑ | テクニカルサポートはどうなりますか？
Ａ | Magicサポート（有償）で対応します。 インシデントによりテクニカルなご質問に回答します。 詳細は、「サポート契約のご案内」をご確認ください。
 | Totop


Magic Software Japan K.K - Magic eDeveloper Plus Ver9.40J SP1 ベータ版 （Windows版）

ReportsMagic V2 使用許諾契約書

MSJC-RM100-1

本ソフトウェアモジュールを利用するにあたっては、下記の事項を良く理解し、合意した上でご利用ください。万一合意できない場合には、本ソフトウェアモジュールをご利用になることはできません。

マジックソフトウェア・ジャパン株式会社（以下「ＭＳＪ」という）とお客様（以下「お客様」という）は、このパッケージに同封されているソフトウェア・プログラム（以下「許諾プログラム」という）及び同封物（マニュアルなど）について以下の通り合意しました。なお、本契約書に関するお問い合わせは、マジックソフトウェア・ジャパン株式会社（以下「ＭＳＪ」という）まで書面にてご連絡いただきますようお願い致します。

1. | 総則
   許諾プログラムに関する全ての著作権は、ＭＳＪが保有しています。ＭＳＪはお客様に、以下条項の規定に従って、許諾プログラムの譲渡不能かつ非独占的で限定された使用権を許諾するものであり、販売するものではありません。
2. | 契約期間
   本契約は、お客様がこのパッケージを開封した時から発効し、お客様が文書により解約を申し入れるか、または第７条の規定により解約されるまで有効とします。
3. | 使用権
   使用権の内容はお客様が購入又は入手された許諾プログラムの種類により異なります。お客様はパッケージに表記された種類に従い、以下の使用権の内容を遵守して下さい。
・RMDesignerの場合
  お客様は、許諾プログラムを機械読取可能な形で、特定の１台のコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途ＭＳＪより取得しなければなりません。
・RMViewer－C/Sの場合
  お客様は、許諾プログラムを機械読取可能な形で、お客様が購入したユーザ数分を同時にコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。またお客様がマルチターミナル・システムで許諾プログラムを使用する場合は、接続される端末数分の使用権を別途ＭＳＪより取得しなければなりません。
・RMViewer－Webの場合
  お客様は、許諾プログラムを機械読取可能な形で、サーバ単位で使用することができます。
・RMViewer－RichClientの場合
    お客様は、許諾プログラムを機械読取可能な形で、サーバ単位又は、お客様が購入したユーザ数分を同時にコンピュータ・システムにおいて使用すること（以下「使用権」という）ができます。ユーザ数の場合は、Magic xpa RIA Server/uniPaaS RichClient Server と同じユーザ数分の使用権をＭＳＪより取得しなければなりません。Magic xpa RIA Server/uniPaaS RichClient Serverのシステムのみで使用することができます。
・体験版の場合
  お客様は、試用目的でだけ許諾プログラムを使用することができます。許諾プログラム、及び許諾プログラムを利用して開発したモジュールを営利目的に使用することはできません。
4. | 制限
   お客様は、以下の行為をしてはならないものとします。（但し、MSJによる書面による同意がある場合は、この限りではありません。）
(1) 許諾プログラムあるいはその使用権の譲渡、移転、または再使用権の設定を行うこと。
(2) 許諾プログラムあるいはその使用権をレンタル、リースまたは貸与すること。
(3) 許諾プログラムを改変、リバースエンジニアリングまたは逆アセンブルすること。
(4) 許諾プログラムの技術的な制限を回避する方法で利用すること。
(5) ＡＳＰやＳａａＳあるいはその他の方法で、第三者の業務処理目的で許諾プログラムを当該第三者に使用させること。(商用ホスティングサービスを含む)
5. | 許諾プログラム等の複製
   (1) お客様は、許諾プログラムの複製物を作成してはなりません。但し、バックアップを目的とする場合に限り、機械読取可能な形で許諾プログラムの複製物を２部まで作成することができます。
(2) お客様は、許諾プログラムのすべての複製物に、許諾プログラムに付されている著作権表示およびその他の権利表示を付すものとします。
(3) お客様は、このパッケージの許諾プログラム以外の同封物の一部、または全部の複製物を作成する場合には、ＭＳＪの事前の許諾を得るものとします。
6. | ＭＳＪの保証の範囲
   (1) ＭＳＪは許諾プログラムがお客様の特定の使用目的に合致し、また、いかなる場合でもその実行に誤りがないことを保証するものではありません。但し、お客様が登録カードを返送し、かつお客様が許諾プログラムを通常の方法で使用している場合に限り、許諾プログラム購入の日から３箇月以内に指定プログラムの誤り（バグ）を修正したソフトウェア・プログラムが発表されたときには、その修正したソフトウェア・プログラムまたは修正したソフトウェア・プログラムに関する情報を提供します。これをもってＭＳＪの唯一の保証とします。
(2) ＭＳＪの責任は、第６条(1)項に規定された保証のみに限定されるものとし、許諾プログラムを使用することにより生じたいかなる損害についてもその責は負いません。
7. | 契約の解約
   ＭＳＪは、お客様が本契約に定める事項に違反したとき、またはお客様において本契約を継続しがたい重大な事由があるときは、お客様に対し、何らの事前の通知なしに直ちに本契約を解約できるものとします。
8. | 契約終了時の措置
   本契約が第７条により解約された場合またはその他の事由により本契約が終了した場合、お客様は本契約が終了した日より１０日以内にインストールされた許諾プログラムのデータ及び許諾プログラムを格納した媒体並びにそれらの複製物を廃棄するものとします。
9. | 一般条項
   本契約のいずれかの条項またはその一部が法令により無効となった場合でも、その他の条項は、有効に存続するものとします。
10. | 準拠法および裁判管轄
   本契約は日本法に準拠するものとし、本契約に関する訴えは、東京地方裁判所をもって第一審の専属管轄裁判所とします。

マジックソフトウェア・ジャパン株式会社


ReportsMagic Ver1.0A 修正履歴

V1.0Aの改善・変更内容

dbFORM

  • dbFORMフォームの読込で、項目にアンダーバーが付く件に対応しました。
  • dbFORMフォームの読込で、横倍角に対応しました。
  • dbFORM形式でイメージデータが表示されない件に対応しました。
    文字列／データ項目名の最後の文字を I にします。　例：％％１７－４Ｉ

データ連携

  • CSV形式で、印刷データにシングルバイトの"が含まれると正しくデータ認識できない件に対応しました。
    シングルバイトの"を含めたい場合は、""と表現します。
  • XML形式で、印刷データに、シングルバイトの"や、&quot;が含まれると正しくデータ認識できない件に対応しました。

その他

  • 「テスト実行」を行うと、フォームの項目名が実データに更新される場合がある件に対応しました。
  • スタティック（固定）文字列は、枠を表示をしないようにしました。
  • バーコードのデータが不正な場合は、「バーコードエラー」と表示するようになりました。
  • 文字列でテキストに下線を指定した場合、スペース部分は下線が引かれない件に対応しました。

RMViewer

  • フォームファイルをオープンし印刷データ取り込み前は、項目データが項目タグ名や、サンプルが表示されている件に対応しました。


ReportsMagic Ver1.0B 修正履歴

V1.0Bの新機能

イメージ
  • イメージをデータ項目として使用する場合、イメージ形式としてJPEGに対応しました。

RMViewer

各種コマンドパラメータが拡張されました。

  • 印刷中表示画面の表示・非表示の指定(コマンドパラメータ指定)
    /status=[y/n]
    y:表示（デフォｒント）
    N:非表示
  • 印刷部数の指定(コマンドパラメータ指定)
    /copy=[部数]

RMViewer起動用DLL

  • Ver1.0～Ver1.0A RMViewer実行関数(ExecuteO)
      構文……定義式：RMViewer.ExecuteO
      バラメータ……
      ①フォームファイル名（文字型）
      ②データファイル名（文字型）
      ③プリンタ名（文字型）
      ④RMViewerの実行フォルダ。（文字型）指定がない場合には、カレントフォルダーになります。
      ⑤プレビューあり/プレビューなし（文字型） （’y’ または ‘n’で指定）
      ⑥ウェイトを指定します。（文字型） （’y’ または ‘n’で指定）
      ⑦実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑧エラーメッセージ（文字型）

  • Ver1.0B RMViewer実行関数(Execute)　　　　　　　 ＜Ver1.0Bで拡張された定義式＞
      構文……定義式：RMViewer.Execute
      バラメータ……
      ①フォームファイル名（文字型）
      ②データファイル名（文字型）
      ③プリンタ名（文字型）
      ④RMViewerの実行フォルダ。（文字型）指定がない場合には、カレントフォルダーになります。
      ⑤プレビューあり/プレビューなし（文字型） （'y' または'n'で指定）
      ⑥ウェイトを指定します。（文字型） （'y' または 'n'で指定）
      ⑦印刷部数の指定（文字型） ※Ver1.0Bで追加されたパラメータ
      ⑧印刷中表示画面の表示・非表示の指定 （'y'表示（デフォルト）n:非表示） ※Ver1.0Bで追加されたパラメータ
      ⑨実行結果のエラー番号（数値型）負付きの数値型３桁で返します。
      ⑩エラーメッセージ（文字型）

Ver1.0B RMViewer起動パラメータの機能拡張に伴い、RMViewer起動用DLLのパラメータも拡張されました。これにより、V1.0～V1.0AでRMViewer実行関数(Execute)を使用したMagicアプリケーションは、コールユーザPRC実行後に「ユーザー関数、またはユーザープロシジャの引数の数が合っていません。」のエラーが発生 するようになります。
  その場合は、Magicアプリケーションの定義式RMViewer.ExecuteをRMViewer.ExecuteOに変更します。テキスト検索、テキスト置換を使用すると容易に移行することが可能です。
  Magicアプリケーションを変更せずに使用したい場合は、Ver1.0～Ver1.0A用のRMViewer起動用DLLを使用することにより可能です。ただし、拡張された機能を使用することが出来ません。今後の拡張にも対応することが出来なくなる為、移行することをお奨めいたします。
今後パラメータ仕様が変更（拡張）される場合は、定義名の追加等により、Magicアプリケーションの互換性が維持できるように考慮いたします。

RMViererCtrl(ActiveX）

  • プリンタ名をパラメータで指定
    CallCom
    プロパティ：PrinterName
    パラメータ値：[プリンタ名]

    HTMLでの指定：
    <param name="PrinterName" value="[プリンタ名]"

  • 印刷部数を指定する
    CallCom
    プロパティ：Copy
    パラメータ値：[部数(文字列)]

    HTMLでの指定：
    <param name="Copy" value="[部数]"

  • ページ指定の対応
    CallCom
    プロパティ：PageSelect
    パラメータ値：なし

V1.0Bの改善・変更内容

RMDesigner

  • カウントアップ複写を行った場合、項目名、項目タグがカウントアップされない件に対応しました。
  • テスト表示で複数ページ表示した場合、先頭ページ/最終ページのボタンがアクティブにならない件に対応しました。
  • 文字列で塗りつぶしを指定した場合は、文字枠全体を塗りつぶすようになりました。
  • テーブルで背景色を指定したとき、無条件に横罫線が出力される件に対応しました。

データ連携

  • dbFORM形式で、項目の「テキストの折り返し」が有効にならない件に対応しました。
    「テキストの折り返し」がチェックされている場合は、ReportsMagicの文書枠のサイズに沿ってて出力します。
    「テキストの折り返し」がチェックされていない場合は、ReportsMagicの文書枠のサイズを無視して出力します。

    dbFORMの文章データには枠サイズがありますが、文字の場合は枠サイズが存在しません。
    従って、dbFORMのフォームを読み込んだ場合 、文字は「テキストの折り返し」がチェックなし、文章は、「テキストの折り返し」がチェックありで設定されます。
  • dbFORM形式で全タグに差込データを設定していない状態で「ＦＦ」で出力した場合、設定されていないタグは前ページ以前に出力した内容が出力される件に対応しました。
  • XML形式で全タグに差込データを設定していない状態で明示的改ページを実施した場合、設定されていないタグは前ページ以前に出力した内容が出力される件に対応しました。
  • CSV形式で、Key指定が無い場合には、1レコードが1ページと認識できずに、最後のレコードのみが出力される件に対応しました。

データ項目ウインドウ

  • データ項目ウインドウで一旦項目を削除すると、再びデータを読み込んでも再定義されない件に対応しました。

その他

  • 文字列属性の「テキストの長さに合わせてフォントサイズを調節」は、「縮小して全体を出力」に変更されました。
    従来は、表示領域に格納できる最大フォントサイズを計算して表示していましたが、指定されたフォントサイズ、文字ピッチで表示領域に出力できない場合のみ、フォントサイズ 、文字ピッチを小さくして全体を 出力するようになりました。
    複数行はサポートしていません。「テキストの折りかえし」を指定しても無視されます。
  • フォームを上書き保存をするとファイルサイズが２倍近く大きくなる件に対応しました。
  • シュートカットが変更されました。詳細は、参考技術情報を参照してください。

RMViewer

  • 複数ページを表示した場合、先頭ページ/最終ページ/指定ページが有効にならない件に対応しました。
  • 複数ページを表示した状態で印刷を実行すると常に最終ページが表示されていましたが、印刷を開始したページが表示されるようになりました。
  • フォーム「帳票設定」で指定した用紙サイズや給紙方法が反映されない場合がある件に対応しました。


ワトソン博士のログのとり方

目次

  1. ワトソン博士とは？
  2. ワトソン博士を使ってログを取るための準備
  3. プログラムがクラッシュする場合のダイアログ
  4. プログラムがハングアップする場合の処置
  5. ワトソン博士が出力したログとクラッシュダンプファイルの送付
  6. 参考情報
    • クラッシュ ダンプ ファイルを作成しないようにする方法
    • より詳しい説明

1. ワトソン博士とは？

ワトソン博士(Dr. Watson)というのは、Microsoft社が提供するWindowsアプリケーションのためのデバッグ用ツールです。ワトソン博士をあらかじめデフォルトのデバッガとして登録しておけば、Windows上で動作するアプリケーションが異常終了した場合に、その時点での各種内部状態の記録(ログ)を作成し、保存します。アプリケーションの開発者はそのログをもとにして異常終了した状態を解析し、デバッグすることができます。

ここでは、ワトソン博士の設定方法、できるログファイル等について基本的なことをごく簡単に説明します。

2. ワトソン博士を使ってログを取るための準備

STEP 1. ワトソン博士をデバッガとして設定する

最初に、ワトソン博士をシステムで使うデフォルトのデバッガとして登録しなければなりません。これには、コマンドプロンプト(DOS窓)で、

drwtsn32 -i

とタイプすることによりなされます。このコマンドは、Administrator 権限のあるユーザだけでしか実行できません。

登録をいったん行うと、この設定はレジストリに書き込まれますので、マシンを再起動しても、再度実行する必要はありません。

登録に成功すると、下図のようなダイアログが表示されます。

STEP 2. ワトソン博士の設定を確認する

次に、ワトソン博士の設定を確認します。コマンドプロンプトから、今度は引数なしで

drwtsn32

を実行すると、次のような設定ダイアログが表示されます。

このうち、「ログファイルパス」は、ログファイルを保存しておくディレクトリ名を指定し、デフォルトでは「c:\Documents and Settings\All Users\Application Data\Microsoft\Dr Watson」などになっていますが、Windowsのバージョンにより違う場合があるので、確認して記録しておいてください。

ここに記録されるログファイルには、異常終了した時点でのメモリやレジスターの内部状態などの基本的な情報がテキスト形式で記録されます。

ログファイルに記録されているものだけでは情報不足で、異常終了時のプログラムのメモリの状態全部がデバッグに必要になることがあります。ワトソン博士では、これを「クラッシュダンプファイル」と呼び、設定ダイアログの「クラッシュダンプファイルの作成」にチェックが入っている場合に、「クラッシュダンプ」で指定されたディレクトリに作成します。

クラッシュダンプファイルはデバッグに極めて有効ですので、問題解決の時にはこれが取られるように、「クラッシュダンプファイルの作成」にチェックをしておいてください。

ただし、このファイルはプロセスのメモリ空間全体と付随情報を保存するので、サイズが非常に大きくなりがちです。たとえば、Magic のエンジンが異常終了した場合には、数十MBのサイズになります。このため、クラッシュダンプファイルの作成は問題解決に必要な場合に限り、普通は取らないようにチェックをはずしておくのが良いでしょう。

以上で、ワトソン博士の設定は終了です。実際にプログラムを動かしてテストを開始してください。

3. プログラムが異常終了する場合のダイアログ

プログラムの実行中に、アクセス違反、ハンドルされない例外などが発生してプロセスが異常終了したら、次のようなエラーダイアログが表示されます。ここのボタンが「キャンセル」になっている間は、ログファイルを作成中ですので、ボタンを押さないでください。クラッシュダンプファイルを作成する設定になっていると、このダイアログのボタンが「キャンセル」から「OK」に変わるまで、1分程度の時間がかかることがあります。

ボタンが「キャンセル」から「OK」に変わったら、ログファイルおよびクラッシュダンプファイルの作成は完了したので、OKを押してください。

4. プログラムがハングアップする場合の処置

プログラムの実行時に、異常終了はしないものの、プロセスが反応しなくなることもよくあります。この場合、無限ループに陥り、CPUを100%近く消費してしまっている場合もありますし、逆に、何かの待ち状態が続くようになってしまって、CPUが0%であることもあります。

いずれの場合にも、プログラムを強制終了させる必要がありますが、これには主に2つの方法があります。

  1. タスクマネージャからプロセスを強制終了させる方法
  2. ワトソン博士を使ってプロセスを強制終了させる方法

ここでは、ワトソン博士を使ってプロセスを強制終了させる方法について説明します。ワトソン博士を使って強制終了させることにより、タスクマネージャでは終了させられないサービスのプロセスを終了させることもでき、また、異常終了の場合と同様なログとクラッシュダンプファイルを取得することもできます。

STEP 1. プロセスIDを識別する

タスクマネージャなどで、ハングアップしているプロセス(強制終了させたいプロセス)のプロセスIDを識別します。

無限ループになっている場合には、「CPU」欄の値が 99 など、ほぼ100に近い数値になっているものがそれです(System Idle Process というのがありますが、これは無視してください。これは、本当の意味でのプロセスではなく、CPU負荷がほぼ0%の時には、System Idle Processの「CPU」が99近くになっています)。

逆に、永遠の待ち状態になっている場合には、時間が経ってもCPUの値とかメモリ使用量とかが変動しないので、判別することができます。通常活動を行っているプロセスは、時間とともにこれらの値が変動します。

STEP 2. drwtsn32.exe を実行する

プロセスIDが取得できたら、コマンドプロンプトから次のコマンドを実行します。ここで、pid は、STEP 1で取得したプロセスIDです。

drwtsn32 -p pid

このコマンドを実行すると、「プログラムのクラッシュする場合のダイアログ」で示したのと同様のダイアログが表示されます。クラッシュダンプファイルを採取する場合には、ボタンの表示が「OK」になるまで待ってください。クラッシュダンプファイルを採取する必要がない場合には、「キャンセル」ボタンを押して構いません。

5. ワトソン博士が出力したログとクラッシュダンプファイルの送付

STEP 1. ログファイルとクラッシュダンプファイルの送付

ワトソン博士の出力したログファイル (drwtsn32.log) は、ダイアログで設定されたディレクトリに保存されています。このファイルをコピーして、適当な形式(LZH、ZIPなど)で圧縮し、サポートセンターへお送りください。サイズが大きくなるので、圧縮しても大きすぎる場合には、CD-Rなどにコピーしてください。

[注意] ログファイル drwtsn32.log は、異常終了のあるたびに追加書き込みされ、サイズがだんだん増えてきますので、適宜削除してください。一方、クラッシュダンプファイル user.dmp は異常終了のあるたびに上書きされますので、必要ならば、別名に変更するなどして保存しておいてください。

STEP 2. モジュールの DIR の結果の送付

モジュールのバージョンを正確に把握するため、Magicをインストールしたディレクトリで、下図のように、dir コマンドを使って Magic関係のモジュールのタイムスタンプ、サイズなどを取得し、その結果を適当なファイルに格納して、上記のログファイル等と一緒にサポートセンターへお送りください。

[参考] dir コマンドの結果(上図で modules.txt の中身)は、次のようなものです。これは例ですので、Magicのバージョン等により結果が異なります。

ドライブ D のボリューム ラベルは S359897D001 です
 ボリューム シリアル番号は 488B-6C1C です

 D:\Program Files\Magic\Development のディレクトリ

2002/11/19  13:22               49,220 MGActDir.dll
2002/12/10  20:18              204,713 MGBC930_03AJ.cab
2002/11/25  13:45               97,522 MGBC930_03AJ.js
2002/12/10  20:19              203,714 MGBC930_03AJS.cab
2002/12/10  20:19              204,454 MGBC930_03AJS_FW01.cab
2002/12/10  20:19              204,678 MGBC930_03AJ_FW01.cab
2002/12/10  20:07               97,460 MGBC930_03AJ_FW01.js
2002/11/19  16:16               19,401 MGBCCOM9.cab
2002/12/03  19:27              225,345 MGddf.dll
2002/12/03  19:31              225,347 MGddf2k.dll
2000/03/16  01:34                2,206 mgedit.jpg
2002/12/13  14:31                  121 mgflwmtr.log
2002/12/11  18:34            5,726,274 MGgenw.exe
2002/12/03  19:35               86,084 MGlcl9jp.dll
2002/12/03  17:38              118,851 MGmerge.dll
1999/01/06  11:41                  435 MGPRN.CNT
1999/06/18  10:08              110,592 MGPRN.EXE
2001/05/24  08:38              319,218 MGPRN.HLP
2002/12/13  14:18                  625 mgrb.ini
2002/05/11  09:04                  822 mgreq.ini
2002/12/03  17:29              548,931 MGresrc.dll
2002/12/11  18:34            3,584,066 MGrntw.exe
2002/12/05  15:26              102,468 MGrqcmdl.exe
2002/12/03  19:35              667,718 MGrqgnrc93.dll
2002/12/03  19:21               98,374 MGrqhttp93.dll
2002/12/03  19:20              217,155 MGrqmrb.exe
2002/12/03  19:35              352,324 MGrqsoap.dll
1999/04/21  00:19              253,952 MGVAR.ocx
2000/02/28  17:56                2,672 mgvcr.jpg
2002/11/19  13:34              143,426 MG_ocx.dll
              30 個のファイル          13,868,168 バイト

 D:\Program Files\Magic\Development\EJB のディレクトリ

2002/07/24  09:07               31,886 mgejbgnrc.jar
               1 個のファイル              31,886 バイト

 D:\Program Files\Magic\Development\Gateways のディレクトリ

2002/12/05  15:26              331,842 MGbtrv.dll
2002/12/05  15:26              319,556 MGmemory.dll
2002/12/05  15:26              331,842 MGpv2k.dll
               3 個のファイル             983,240 バイト

 D:\Program Files\Magic\Development\Magic9Demo\HTML_Pages のディレクトリ

2001/02/16  12:23                  240 mg_vcr.gif
               1 個のファイル                 240 バイト

 D:\Program Files\Magic\Development\Support のディレクトリ

2002/12/03  10:47              759,085 mgconstw.eng
2002/12/05  16:59              759,033 mgconstw.jp2
2002/12/05  16:58              759,032 mgconstw.jpn
2002/09/26  11:39                8,467 MGHELPW.CNT
2002/12/10  16:08            3,114,135 MGHELPW.HLP
               5 個のファイル           5,399,752 バイト

     ファイルの総数:
              40 個のファイル          20,283,286 バイト
               0 個のディレクトリ     328,677,376 バイトの空き領域

6. 参考情報

6.1. クラッシュ ダンプ ファイルを作成しないようにする方法

問題解決の時には、クラッシュダンプファイルは非常に有効なので、できるだけ取るようにしていただきたいと思いますが、問題の調査が終わり、通常の運用に戻った場合には、クラッシュダンプファイルは作成する必要がありませんので、次のステップでクラッシュダンプファイルを作成しないように設定を変更します。

STEP 1. ワトソン博士の設定ダイアログを起動する

Administrator 権限のあるユーザだけでログインし、コマンドプロンプト(DOS窓)で、引数なしで

drwtsn32

を実行します。するとワトソン博士の設定ダイアログが出てきます。

STEP 2. 「クラッシュダンプファイルを作成する」のチェックをはずす

設定ダイアログの中で、「クラッシュダンプファイルの作成(T)」のチェックボックスをはずします。すると、「クラッシュ ダンプ (P)」の欄が無効化されます。これで「OK」ボタンを押すと、以後、万一プログラムが異常終了しても、比較的サイズの小さいログだけが作成され、クラッシュダンプファイルは作成されなくなります。

この設定はレジストリに書き込まれますので、マシンを再起動しても、再度実行する必要はありません。

6.2. より詳しい説明

ワトソン博士の使い方の詳細については、コマンドプロンプトで

drwtsn32

を実行させると、ワトソン博士の設定ダイアログが出てくるので、「ヘルプ」ボタンを押してワトソン博士のヘルプを読んでください。